Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox Maintenance

2010+ Equinox Maintenance

starting problems


This is a discussion on starting problems within the 2010+ Equinox Maintenance forums, part of the Chevy Equinox General Discussion category!
My 2005 equinox is having occational problems starting. When i turn key it cranks then it continues to crank after ...





Reply
 
LinkBack Thread Tools Display Modes
Old 05-14-2012, 10:14 PM   #1 (permalink)
Junior Member
 
Join Date: May 2012
Posts: 1
Rep Power: 0
dan112 is on a distinguished road
Default starting problems

My 2005 equinox is having occational problems starting. When i turn key it cranks then it continues to crank after i let go of key for a few seconds. if i wait a while it usually starts but when it starts the rpms dip for a second then it runs fine this has happened twice this month(once for over ten minutes wouldnt start) i just bought car 3 months ago. I would think it is some sort of fuel pump issue but it runs great. I googled problem seems alot of people have the same or similar problems with no solutions some have changed fuel pump, fuel filter ignition, some sort of security lockout with the key, and one guy had the computer changed all with no luck.
dan112 is offline   Reply With Quote
Old 05-15-2012, 01:14 PM   #2 (permalink)
Senior Member
 
TheDarkKnightKnox's Avatar
 
Join Date: Apr 2012
Location: Columbus, OHIO
Age: 34
Posts: 268
Rep Power: 8
TheDarkKnightKnox is on a distinguished road
Default

We were having similar issues with our 05, I actually replaced plugs and wires as well as took apart the air intake on top of the engine. It was caked up with Carbon and was restricting air into the engine when idling. The issue cleared up after the cleaning.
TheDarkKnightKnox is offline   Reply With Quote
Old 05-01-2015, 10:12 AM   #3 (permalink)
Junior Member
 
Join Date: May 2015
Posts: 4
Rep Power: 0
jtwicked82 is on a distinguished road
Default

I have a 2010 Chevy Equinox, and it will not start, no cranking, nothing. We've replaced battery, ignition, computer, now a blown fuse box. Is this issue similar to yours not starting?
jtwicked82 is offline   Reply With Quote
Old 07-20-2015, 06:04 PM   #4 (permalink)
Junior Member
 
chevyboy3199's Avatar
 
Join Date: Aug 2014
Age: 49
Posts: 4
Rep Power: 0
chevyboy3199 is on a distinguished road
Default

Ours "dieseled" or over cranked continuously once but i t hasn't happend again, what causes this?

Sent from my XT1093 using Tapatalk
chevyboy3199 is offline   Reply With Quote
Old 09-25-2015, 11:09 PM   #5 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Originally Posted by dan112 View Post
My 2005 equinox is having occational problems starting. When i turn key it cranks then it continues to crank after i let go of key for a few seconds. if i wait a while it usually starts but when it starts the rpms dip for a second then it runs fine this has happened twice this month(once for over ten minutes wouldnt start) i just bought car 3 months ago. I would think it is some sort of fuel pump issue but it runs great. I googled problem seems alot of people have the same or similar problems with no solutions some have changed fuel pump, fuel filter ignition, some sort of security lockout with the key, and one guy had the computer changed all with no luck.
Did you ever get this resolved?
dietz4ibanez is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is anyone having problems with their 2011? DeeDee1202 2010+ Equinox General Forum 9 01-04-2016 11:26 AM
Blower problems Jaws 05-09 Equinox Maintenance 9 12-12-2015 04:09 PM
2010 Equinox LTZ 6 cyl starting problem johns4949 2010+ Equinox General Forum 5 05-01-2015 10:13 AM
Starting problems, gas smell, shifting issues.. Helene74 2010+ Equinox Maintenance 13 05-22-2012 08:25 AM
problem with starting point on navigation cyndi516 The Official "How To:" Section 2 04-16-2011 10:41 PM