Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox Maintenance

2010+ Equinox Maintenance

2011 chevy equinox running rough and stalling. Please help.


This is a discussion on 2011 chevy equinox running rough and stalling. Please help. within the 2010+ Equinox Maintenance forums, part of the Chevy Equinox General Discussion category!
My 2011 chevy equinox has been running rough for past 6 months its been feeling jerky sometimes stall when im ...





Reply
 
LinkBack Thread Tools Display Modes
Old 11-27-2018, 10:48 AM   #1 (permalink)
Junior Member
 
Join Date: Nov 2018
Age: 28
Posts: 2
Rep Power: 0
Ftrevino19 is on a distinguished road
Default 2011 chevy equinox running rough and stalling. Please help.

My 2011 chevy equinox has been running rough for past 6 months its been feeling jerky sometimes stall when im at a light, sometimes hesitates when pressing on the gas. All this started happening after getting caught in middle of a bad flood had to drive through it for a bit to get to higher grounds. Car didnt act up that night,next day engine light came on.. No milky like oil or water in air filter but was a bad o2 sensor. I changed it out. worked fine for a couple weeks. Then started running rough again. Bad o2 sensor again same one. Changed it out worked fine for a few weeks. THen again started running rough. Code came up it was a bad Catalytic converter. Dealer changed it out and high pressure fuel pump. Covered by dealer due to recalls. That seemed to fix the problem for a few months. Well about a week ago it start acting funny again. Car went into "reduced engine power" mode. Came up tps was no good. So of course changed it out with the throttle body its one unit.. Work for a couple days, but now running rough again. Took it to a mechanic says only thing is coming up is a bad o2 sensor. The same one ive replaced twice already. I explained to him about driving through flooded water some time back. Says maybe the computer got damaged when i drove through the water which could be why i keep getting different codes. I havent changed out the o2 sensor yet. Please help
Ftrevino19 is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 equinox running rough Ftrevino19 2010+ Equinox Maintenance 0 11-26-2018 07:48 PM
2011 Equinox Stalling rarr201341 2010+ Equinox General Forum 3 09-29-2017 04:17 PM
2011 Equinox stalling RRoark 2010+ Equinox Maintenance 1 09-21-2017 07:10 PM
Rough Idle on 2011 Equinox Newtodanox 2010+ Equinox General Forum 2 01-31-2017 11:09 AM
2011 Equinox Stalling btweymouth1s 2010+ Equinox Maintenance 0 04-19-2016 09:45 AM