Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

Is anyone having problems with their 2011?


This is a discussion on Is anyone having problems with their 2011? within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
Hello everyone! New to the site I purchased a 2011 equinox about 5 months ago and have experianced several problems ...





Reply
 
LinkBack Thread Tools Display Modes
Old 03-26-2011, 12:52 AM   #1 (permalink)
Junior Member
 
Join Date: Mar 2011
Age: 41
Posts: 1
Rep Power: 0
DeeDee1202 is on a distinguished road
Smile Is anyone having problems with their 2011?

Hello everyone!

New to the site I purchased a 2011 equinox about 5 months ago and have experianced several problems with the heat going out! I have to bring it back again on monday to have it checked out again, but this is the 3rd time its been back in the shop for the same problem within the last month and a half. Anyone having these similar issues? Also had to bring it in 2 other times for the car automaticly turning off while im trying to make sharp turn left or right. The steering wheel locks and the car shuts off, any thoughts on what it could be? The dealership claimed it was a problem with the igination switch and repaired it but it did it again so i know thats not the problem. Any feed back would be appreciated
DeeDee1202 is offline   Reply With Quote
Old 03-26-2011, 06:44 AM   #2 (permalink)
Crossover Professional
 
08PILOT's Avatar
 
Join Date: Jan 2011
Location: West TN
Age: 50
Posts: 832
Rep Power: 10
08PILOT is on a distinguished road
Default

Welcome 2 CEF, That turning issue sounds scary

I have an OBS (Old Body Style) so I have not had
the heat issues you speak of. Is where your going
the only Dealership option in your area? Reason I
ask is I'm concerned about their knowledge base.

Seems weird for u to have various repeat issues,
especially after having it quote "Fixed" already.
__________________
The Wife's: "WD1" 08 AWD Nox Sport
The Toy: "Square Vette" 72 C5 Blazer
Toy Puller: "Burakkubyūtī" 12 Tundra
Toy Hauler: "Feathers" Aluma 8218T
Owner/Admin "TN Classic Truck Club"
08PILOT is offline   Reply With Quote
Old 03-26-2011, 08:07 AM   #3 (permalink)
Junior Member
 
SPH01's Avatar
 
Join Date: Jan 2011
Location: Southern California
Posts: 11
Rep Power: 0
SPH01 is on a distinguished road
Default Stalling

I would look under the General discussions section under the stalling issues for 2011. As far as the no heat issue, my 2010 had the brains changed out about 6 months ago on a recall for the AC/Heat controller.
And I have to agree do you have another GM dealer in the area?
My goes into a Cadillac Dealer across the street from the Chevy dealer because of their reputaion. ANY GM dealer can do warrenty work on it.
SPH01 is offline   Reply With Quote
Old 03-26-2011, 04:25 PM   #4 (permalink)
Super Mod
 
Z_Ghost's Avatar
 
Join Date: Nov 2010
Location: Texas
Age: 62
Posts: 1,586
Rep Power: 11
Z_Ghost is on a distinguished road
Default

got 3000 miles on my Terrain and the only problem I have had was a strange start up one time that felt it was only running on 1 cylinder.
Other then that all has been good
__________________
2011 Terrain SLT2 Carbon Black I4 FWD
92 B4C Camaro - X Texas HWY Patrol car
ZZ4, SuperRam, Holley 52 mm TB, T-56.
92 Z/28
60\'1.937-1/4 13.851-98.16 mph

Z_Ghost is offline   Reply With Quote
Old 03-26-2011, 10:48 PM   #5 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 37
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

I would tell the dealer that the issue with the nox cutting off when sharp turn is going on has to be the safety feature sensor for roll over that cuts off the vehicle if it were in a wreck. I would ask them to replace whatever sensor there may be if there is such a safety feature.

There is a recall for the other issue with the heat.
dietz4ibanez is offline   Reply With Quote
Old 03-26-2011, 10:53 PM   #6 (permalink)
Member
 
Join Date: Feb 2011
Posts: 46
Rep Power: 0
Colt Hero is on a distinguished road
Default

2500 miles and no problems that I KNOW of. I say "KNOW OF" because I really haven't tested everything on the car yet, and for all I know, half the stuff doesn't work!!

Normally, I would do this checkout at the dealership BEFORE purchasing (I've even made checklists in the past to make sure I tested everything), but I had to move fast on this purchase this time, and so I let it slide.

The wife DID recently complain that the A/C didn't seem to cool, but I haven't verified that yet. There's also a single "CLOP" noise when turning the wheel after startup that some say is normal (from the ABS). To me, it sounds just like the beginning of a CV joint problem. I also have power steering "moan" when I turn the wheel. Could be a bad PS unit on the horizon (or maybe even the entire rack).

But other than that, everything's fine ...
Colt Hero is offline   Reply With Quote
Old 04-09-2011, 05:13 PM   #7 (permalink)
Junior Member
 
CKeshen's Avatar
 
Join Date: Mar 2011
Location: Florida
Age: 68
Posts: 9
Rep Power: 0
CKeshen is on a distinguished road
Default

I get a moan from the steering too when I turn the wheel, but only when the Terrain is stationary or just barely moving. Had the dealer check it, and was told that was normal. They did check the PS steering fluid level and said that also was normal. Hmmm.

Other than that no problems. Vehicle seems great. Just under 4k miles so far.
CKeshen is offline   Reply With Quote
Old 04-09-2011, 10:23 PM   #8 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 37
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Do you have any updates for us Danielle?
dietz4ibanez is offline   Reply With Quote
Old 11-10-2015, 08:42 AM   #9 (permalink)
Junior Member
 
Join Date: Nov 2015
Age: 31
Posts: 2
Rep Power: 0
lindseymarie is on a distinguished road
Default

what was the cause of your heat problem im currently having this issue.
lindseymarie is offline   Reply With Quote
Old 01-04-2016, 11:26 AM   #10 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 37
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

It could be a bad heater core or thermostat.
dietz4ibanez is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 Equinox problems since purchase equiowner 2010+ Equinox General Forum 4 08-07-2011 04:34 AM