Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum

Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum (http://www.chevyequinoxforum.com/)
-   2010+ Equinox General Forum (http://www.chevyequinoxforum.com/f4/)
-   -   2010 Equinox - Motor and Transmission issues (http://www.chevyequinoxforum.com/f4/2010-equinox-motor-transmission-issues-1600/)

mdt2001 05-10-2016 11:08 PM

2010 Equinox - Motor and Transmission issues
 
I have bought my last Chevrolet. I have a 2010 Equinox that is on its third transmission and second (rebuilt) motor all before 100,000 miles. I have had numerous other issues with the vehicle both front CV joint shafts have been replaced, motor uses oil, ac has gone out, fuel pump replaced, brake master cylinder failed and booster failed, etc….
The motor and transmission where both replaced/rebuilt at 96,000 miles (failed one day / 12 hours after warranty expired. The car had been into the dealership multiple times for excessive oil consumption while vehicle was under warranty, but each time they claimed it was “normal usage” it was burning 2+ quarts every 3,000 miles. Amazingly, after the warranty failed suddenly it was deemed excessive oil consumption and the dealer rebuilt the motor (I had to pay, but they covered some of the cost). They replaced the pistons and rings. At time of repair was told that since I had to pay for the repairs the motor and transmission would have a 3 year 100,000 mile warranty.
One and a half years and 19,000 miles later the rebuilt motor began to leak oil from the crankshaft seal. Brought to Chevrolet and was told that the motor does not have a warranty through Chevrolet, that the warranty is only through the dealership that did the work and it is one year, 12,000 miles and I will have to pay for the repair.
What a great vehicle.


All times are GMT -4. The time now is 06:55 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO