Engine problems

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

jabawalkie101

New member
Joined
Feb 8, 2024
Messages
2
Reaction score
1
I have an 09 equinox sport 3.6. It’s has 160k miles. I have a vacuum leak I’m going to get done but it’s important to note it. I have replaced all camshaft sensors and I still have the error codes “p0017, p0008, p0016, p0018”
I am pretty certain I need to do the timing on the engine. I don’t hear any knocking whatsoever. I took it to a shop to be certain of it. And they told me the engine needed replacing. I can upload their report if necessary. Would these signs I’m having indicate timing? The engine is surging at idle only when it runs for a little. Thanks in advance.
 

cavell

Active member
Joined
Aug 26, 2018
Messages
100
Reaction score
17
How long have you owned it?
the 3.6 does have chain issues and most shops don’t like to deal with comebacks.
 

jabawalkie101

New member
Joined
Feb 8, 2024
Messages
2
Reaction score
1
I purchased it 4 months ago. It sounds like it’s running fine and it feels fine when it runs.
 

cavell

Active member
Joined
Aug 26, 2018
Messages
100
Reaction score
17
a chain job is 1500-2000? A new motor is $5k.
I hear lots of stuff on how poor the 3.6 is.
it works now? Ok suv is worth more.
it has chain issues? It’s worth less
a rig with used ok motor is worth same as one with new motor.
I assume mechanic thru out repair costs?
 
Last edited:

SONNY88

New member
Joined
Aug 18, 2023
Messages
19
Reaction score
4
I have an 09 equinox sport 3.6. It’s has 160k miles. I have a vacuum leak I’m going to get done but it’s important to note it. I have replaced all camshaft sensors and I still have the error codes “p0017, p0008, p0016, p0018”
I am pretty certain I need to do the timing on the engine. I don’t hear any knocking whatsoever. I took it to a shop to be certain of it. And they told me the engine needed replacing. I can upload their report if necessary. Would these signs I’m having indicate timing? The engine is surging at idle only when it runs for a little. Thanks in advance.
I had a similar problem, I think it was a camshaft sensor that went bad on mine. It would crank, go a few feet, then die.
I was right down the street from the dealership, and just made it there the last time.
 

Members online

No members online now.
Top