Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 05-09 Equinox General Forum

05-09 Equinox General Forum

Serivice Stabilatrak/No powersteering


This is a discussion on Serivice Stabilatrak/No powersteering within the 05-09 Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
Last night my wife left work and shortly after pulling out of the lot, she lost her power steering and ...





Reply
 
LinkBack Thread Tools Display Modes
Old 01-10-2014, 08:16 AM   #1 (permalink)
Junior Member
 
Join Date: Oct 2013
Location: Chicago
Posts: 14
Rep Power: 0
DVB1 is on a distinguished road
Default Serivice Stabilatrak/No powersteering

Last night my wife left work and shortly after pulling out of the lot, she lost her power steering and got the "service stabilitrak". The little research I was able to do lead me to checking the 80 amp fuse. Well I never seen a fuse like that nor did I know how to check if it was good or not. I have a multimeter but no clue how to check the fuse with it.

Well this morning I took the EQ to work planning on taking it to the dealer but once I got in, the service light was on for about 5 sec then turned off, I have my steering back too.?? Anybody had this happen?
DVB1 is offline   Reply With Quote
Old 01-11-2014, 06:17 AM   #2 (permalink)
Crossover Professional
 
08PILOT's Avatar
 
Join Date: Jan 2011
Location: West TN
Age: 49
Posts: 832
Rep Power: 9
08PILOT is on a distinguished road
Default

Have had service stabilitrack warnings twice in 5 years. Once
was faulty gas pedal assembly. (It reduced power and said to
service it ASAP in information warning section.) Second was
just last month and was attributed to driving in hard rain for
3 hours straight. (It turned off the AWD and said to service
it ASAP in the warning section.) The 2nd was a soft code, it
cleared out after a few keystrokes. Was weather a factor in
your situation? Or was it just a normal day outside that day?

*There is a thread on here somewhere about my gas pedal.
__________________
The Wife's: "WD1" 08 AWD Nox Sport
The Toy: "Square Vette" 72 C5 Blazer
Toy Puller: "Burakkubyūtī" 12 Tundra
Toy Hauler: "Feathers" Aluma 8218T
Owner/Admin "TN Classic Truck Club"
08PILOT is offline   Reply With Quote
Old 01-11-2014, 10:06 AM   #3 (permalink)
Junior Member
 
Join Date: Oct 2013
Location: Chicago
Posts: 14
Rep Power: 0
DVB1 is on a distinguished road
Default

Originally Posted by 08PILOT View Post
Have had service stabilitrack warnings twice in 5 years. Once
was faulty gas pedal assembly. (It reduced power and said to
service it ASAP in information warning section.) Second was
just last month and was attributed to driving in hard rain for
3 hours straight. (It turned off the AWD and said to service
it ASAP in the warning section.) The 2nd was a soft code, it
cleared out after a few keystrokes. Was weather a factor in
your situation? Or was it just a normal day outside that day?

*There is a thread on here somewhere about my gas pedal.
After work yesterday I drove a good 20 miles with no problems. I'm in Chicago and we got that arctic blast last weekend so the EQ sat for a few days during that time. So I'm thinking/hoping that was the reason. Our temps just shot up the last couple days, we're looking at 40 degree weather for a couple more days (-14 this past Monday). Thanks for your help.
DVB1 is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On