Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 05-09 Equinox General Forum

05-09 Equinox General Forum

2005 Equinox Fuel Pump


This is a discussion on 2005 Equinox Fuel Pump within the 05-09 Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
I have had some problems with my car the last few weeks. It turns over when I turn the ignition, ...





Reply
 
LinkBack Thread Tools Display Modes
Old 03-21-2011, 05:32 PM   #1 (permalink)
Junior Member
 
Join Date: Mar 2011
Posts: 15
Rep Power: 0
Helene74 is on a distinguished road
Default 2005 Equinox Fuel Pump

I have had some problems with my car the last few weeks. It turns over when I turn the ignition, tries to start but dies. When I take the fuse out for the fuel pump, half the fuse looks to be burnt out. After replacing the fuse, the car starts fine for a few days before the fuse needs to be replaced again. I am getting somewhat poor fuel economy and there seems to be some hesitation--not sure whether this is related. Does this sound like the fuel pump or could it be a bad relay?
Does the 2005 Equinox have one or two fuel pumps?

Thanks
Helene74 is offline   Reply With Quote
Old 03-21-2011, 06:17 PM   #2 (permalink)
Crossover Professional
 
08PILOT's Avatar
 
Join Date: Jan 2011
Location: West TN
Age: 49
Posts: 832
Rep Power: 9
08PILOT is on a distinguished road
Default

If fuse is getting burned after a few starts I personally think
your Fuel Pump might be Grounding/Shorting out. I'm not any
kind of expert on this, but I would be worried what's next ?
__________________
The Wife's: "WD1" 08 AWD Nox Sport
The Toy: "Square Vette" 72 C5 Blazer
Toy Puller: "Burakkubyūtī" 12 Tundra
Toy Hauler: "Feathers" Aluma 8218T
Owner/Admin "TN Classic Truck Club"
08PILOT is offline   Reply With Quote
Old 03-21-2011, 08:14 PM   #3 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Do you know when the last time you had the fuel filter changed? My thinking is that if its clogged up it would cause the fuel filter to bog resulting a surge and possibly busting the fuse. Also this could be why the fuel mileage is so bad...

Or it could be the fuel pump going out...

One experience I had like this was my Gf (now wife) Ford Escort would start and other times would not. I put 3 fuel pumps in it and replaced all the sensors under the hood cause it was running bad. Turns out that the heater core had leaked onto the computer and was shorting everything out. New computer equaled a like new car.
dietz4ibanez is offline   Reply With Quote
Old 03-21-2011, 08:19 PM   #4 (permalink)
Junior Member
 
Join Date: Mar 2011
Posts: 15
Rep Power: 0
Helene74 is on a distinguished road
Default

Hi. I was told the fuel filter does not need to be replaced before the fuel pump goes out...as it is suppose to be inside the fuel pump....at least that is what I was told....any ideas?
Helene74 is offline   Reply With Quote
Old 03-21-2011, 10:25 PM   #5 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Oh one of those. That kind of sucks. I would almost bet it would be the fuel pump then in its entirety.

I would suggest trying to get the dealer look into it on the basis that if its the fuel pump they will not charge you for looking it over. Just pay to have it replaced. I hate dealers but would rather take my vehicles there.
dietz4ibanez is offline   Reply With Quote
Old 06-03-2011, 12:05 PM   #6 (permalink)
Junior Member
 
Join Date: Jun 2011
Age: 30
Posts: 4
Rep Power: 0
Joe.Gravelle is on a distinguished road
Default

I believe I have the same issue. This morning my mom called me since her equinox had died and she was on the side of the road. I got there and it would crank but not fire.

She said as she was driving the RPM's dropped/ engine cut off and the accelerator pedal did not do a thing. She coasted to a stop and tried to start but got nothing.

I saw the fuse for the fuel pump was burned out. I replaced it and still a crank/no start situation.

I had it towed to our trusted mechanic and told him. He thinks it too is the fuel pump. I really hope so. We can't really afford another big ticket item.
Joe.Gravelle is offline   Reply With Quote
Old 06-03-2011, 01:35 PM   #7 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Originally Posted by Joe.Gravelle View Post
I believe I have the same issue. This morning my mom called me since her equinox had died and she was on the side of the road. I got there and it would crank but not fire.

She said as she was driving the RPM's dropped/ engine cut off and the accelerator pedal did not do a thing. She coasted to a stop and tried to start but got nothing.

I saw the fuse for the fuel pump was burned out. I replaced it and still a crank/no start situation.

I had it towed to our trusted mechanic and told him. He thinks it too is the fuel pump. I really hope so. We can't really afford another big ticket item.
That sucks.

Hopefully it is a easy fix!
dietz4ibanez is offline   Reply With Quote
Old 06-03-2011, 02:18 PM   #8 (permalink)
Junior Member
 
Join Date: Mar 2011
Posts: 15
Rep Power: 0
Helene74 is on a distinguished road
Default

I had mine replaced...cost me $ 1100!! It is still having some type of issue and some of the same symptoms. I had a speed sensor replaced but that this not seem to cure the full problem either. I have heard these cars have a lot of electrical/fuse problems. I have spent about $ 3000 on it the last month. I was told initially it could be a relay as well so maybe you are lucky. Good luck on it.
Helene74 is offline   Reply With Quote
Old 06-03-2011, 09:33 PM   #9 (permalink)
Senior Member
 
Lenn's Avatar
 
Join Date: Apr 2011
Location: Beaumont, TX
Age: 36
Posts: 192
Rep Power: 9
Lenn is on a distinguished road
Default

My 2006 has a similar problem. Thankfully its not that frequent. I am going to take fuel pressure readings in a couple days as long as it messes up with the guage on it.

Sent from my Droid using Tapatalk
__________________
Lenn is offline   Reply With Quote
Old 06-03-2011, 10:30 PM   #10 (permalink)
Junior Member
 
Join Date: Jun 2011
Age: 30
Posts: 4
Rep Power: 0
Joe.Gravelle is on a distinguished road
Default

Originally Posted by Helene74 View Post
I had mine replaced...cost me $ 1100!! It is still having some type of issue and some of the same symptoms. I had a speed sensor replaced but that this not seem to cure the full problem either. I have heard these cars have a lot of electrical/fuse problems. I have spent about $ 3000 on it the last month. I was told initially it could be a relay as well so maybe you are lucky. Good luck on it.
Did you leave it at the dealership or something? Wow

I brought it to my independent mechanic. I should know by tomorrow, I called him this afternoon and he said his assistant was tearing into it and was far along. Not sure where exactly but I really really hope and pray its just the fuel pump.
Joe.Gravelle is offline   Reply With Quote
Old 06-04-2011, 04:28 AM   #11 (permalink)
Junior Member
 
Join Date: Jun 2011
Age: 39
Posts: 1
Rep Power: 0
lackneramanda is on a distinguished road
Default

While on vacation, the fuel gauge began to stay on zero. Tried filling, but the tank was full. Went to a close GM service location and was told the it was probably a module of some sort and should be no problem driving. mechanic says fuel pump bad. I am not a mechanic, but sounds strange. Just wondered if I was being overly paronoid? Is this a case of faulty diagnosis? Thanks
lackneramanda is offline   Reply With Quote
Old 06-04-2011, 10:33 AM   #12 (permalink)
Junior Member
 
Join Date: Jun 2011
Age: 30
Posts: 4
Rep Power: 0
Joe.Gravelle is on a distinguished road
Default

Got the truck back. Turns out the connector for the fuel pump relay was loose. Thankfully that was it. Has to go back soon to do the right rear wheel bearing/hub since its making a noise.

I also need to do the plugs and wires(regular tune up) since its at that point.
Joe.Gravelle is offline   Reply With Quote
Old 06-04-2011, 01:00 PM   #13 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Good. Glad it was something simple.

Sent from my DROIDX using Tapatalk
dietz4ibanez is offline   Reply With Quote
Old 06-04-2011, 03:46 PM   #14 (permalink)
Junior Member
 
Join Date: Mar 2011
Posts: 15
Rep Power: 0
Helene74 is on a distinguished road
Default

Wish mine would have been that easy or maybe it was and I got ripped off ....Might have to check into that as I am still having issues...thanks for sharing
Helene74 is offline   Reply With Quote
Old 06-04-2011, 03:58 PM   #15 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

How many miles are on your vehicle?
dietz4ibanez is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Economy. dietz4ibanez Engine & Performance Modifications 98 11-26-2012 09:18 PM
What are you paying at the pump? dietz4ibanez The Lounge 86 08-21-2011 05:27 PM
2010 Terrain Fuel Filter ? Shanks12 2010+ Equinox Maintenance 13 04-12-2011 12:11 PM