Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 05-09 Equinox General Forum

05-09 Equinox General Forum

06 LT Will only start in neutral


This is a discussion on 06 LT Will only start in neutral within the 05-09 Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
Howdy! So My daughter bought this Equinox for a song.... We've had a few issues. most of which were easy ...





Reply
 
LinkBack Thread Tools Display Modes
Old 11-27-2016, 11:37 AM   #1 (permalink)
Junior Member
 
Join Date: Nov 2016
Age: 51
Posts: 2
Rep Power: 0
rlshepard is on a distinguished road
Default 06 LT Will only start in neutral

Howdy! So My daughter bought this Equinox for a song.... We've had a few issues. most of which were easy fixes...

Recently the it wouldn't start tap tap on the starter and it fired right up.... so I replaced the starter and all was well... for a while then she went out and no start again. I put it neutral and it fired right up. back to park, fired right up... no she says it will only start in neutral? I'm guessing the neutral safety switch? pricey part... any other things I should look for? anybody have any experience replacing the neutral safety switch? Any adjustment to the linkage or anything on this vehicle?

(Update) after looking at the neutral safety switch I notice two things:

It looks like its been replaced before... Has marking on it like it came from a salvage yard...
The linkage doesn't seem to be secure. Not real sure how it is supposed be secured? I haven't pullec the battery. Compartment yet. Looks like quite the operation?

TIA
Ralph

Last edited by rlshepard; 11-27-2016 at 12:50 PM.
rlshepard is offline   Reply With Quote
Old 11-28-2016, 05:38 PM   #2 (permalink)
Junior Member
 
Ke6zri's Avatar
 
Join Date: Nov 2016
Age: 44
Posts: 14
Rep Power: 0
Ke6zri is on a distinguished road
Default

Might check under shift console to see if there is a park switch that may not be engaging


Sent from my iPhone using Tapatalk
Ke6zri is offline   Reply With Quote
Old 12-14-2016, 11:52 PM   #3 (permalink)
Junior Member
 
Join Date: Nov 2016
Age: 51
Posts: 2
Rep Power: 0
rlshepard is on a distinguished road
Default

Okay, I need some help. So I went to the salvage yard and pulled a neutral safety switch. and the problem was fixed! until now. its back the car will not start in crank in any gear no click no nada. Battery and Started are both new.

I've read some snippets that suggest this could be a key issue? do these keys have a chip? it doesn't look like it does....

Is there a common failure that causes this no crank condition? any test that can tell me if its the PCM or if my salvage neutral switch has failed me?
rlshepard is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Swapped BCM, Car Won't start. Please Help! docstoked 05-09 Equinox Maintenance 2 08-10-2017 10:37 PM
Car won't start after being fueled Bran83 05-09 Equinox General Forum 2 03-22-2016 08:13 AM
Remote Start jsfb6pts 2010+ Equinox General Forum 8 02-18-2014 04:23 AM
Add Remote Start to Nox LS? nolimits76 2010+ Equinox General Forum 14 04-13-2012 07:42 PM
Remote start- No start Z_Ghost 2010+ Equinox General Forum 3 01-15-2011 11:14 AM