Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 05-09 Equinox Maintenance

05-09 Equinox Maintenance

Swapped BCM, Car Won't start. Please Help!


This is a discussion on Swapped BCM, Car Won't start. Please Help! within the 05-09 Equinox Maintenance forums, part of the Chevy Equinox General Discussion category!
Hello all. I have a 2007 Equinox LT. All of this started when I had the sunroof cracked open, and ...





Reply
 
LinkBack Thread Tools Display Modes
Old 08-26-2015, 03:48 PM   #1 (permalink)
Junior Member
 
Join Date: Aug 2015
Posts: 1
Rep Power: 0
docstoked is on a distinguished road
Exclamation Swapped BCM, Car Won't start. Please Help!

Hello all. I have a 2007 Equinox LT. All of this started when I had the sunroof cracked open, and a freak hail storm hit, and i just happened to be parked under a 4inch drain pipe. Within minutes the car had a good 6 inches of hail and water inside. After cleaning and putting a dehumidifier inside it for a week, I thought i would try it and it ran fine with only minor problems. Low-beams worked during the day, not at night, only had high-beams at night. Reverse light didn't work at all. Can't turn off or change the temp of the inside fan. The AC does work, but only one temperature, which is cold. Can't turn the heater on. Also the 3 little blue lights on the Temp control knob, fan speed knob and the zone selector knob ( head only, feet and head, defrost ect.) Stay on permanently. The fog lights don't work either. It was that way for a few weeks and then the check engine light come on and I couldn't use the remote start anymore. I took the car to the dealer for a complete diagnoses and the came back with what needed to be changed was the under-hood fuse box and the BCM, along with the daylight sensor.

I'm somewhat mechanically inclined, but very motivated by poverty and the dealer prices that were thrown my way seemed impossible. So I talked to trusted friends and researched alot and was assured time and again the BCM did not need to be programmed and I could swap it out for a new one. So i carefully disconnected the battery and replaced the fuse box and then moved onto the BCM. I replaced it and hooked everything back up and the car wouldn't turn over.

Lights come on, radio worked, power windows worked, all seemed ok, but no cranking. Couldn't shift from park or lock the doors, either with remote or button. So I pulled out the new BCM and put in the old. Now i can shift from park, all lights door locks with button and remote all work fine, but engine will not start. And now it says service traction control and service airbag which is new. I have done a lot more research but am coming up dry. I have tried something where you leave the key on for 10 mins off for 10secs on for 10min and so on to try and re-program the passlock, but that didn't work.

I would be incredibly grateful for any direction or advice!!!!
docstoked is offline   Reply With Quote
Old 08-28-2015, 09:49 PM   #2 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 35
Posts: 4,669
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

You have to do that Passlock re-learn process and you have to do it right.

I did one a few months ago, if I can remember the sequeance it went something like:

1. Turn the ignition as you were starting the car and don't turn the key off.

2. You'll notice that the messenger center will flash security, stabiltrak, abs and possibly whatever things might be on there as issues. It will rotate them all for about 10 minutes. (I used a timer) at some point at the 10 minute mark it will go solid one of those messages and I believe it was "Security".

3. Turn your car off for a few seconds and do all this.... X3


I believe on the fourth time, your car should start if everything is correct. I know it takes 30 minutes to do this.
dietz4ibanez is offline   Reply With Quote
Old 08-10-2017, 11:37 PM   #3 (permalink)
Junior Member
 
Join Date: Feb 2017
Posts: 3
Rep Power: 0
Kapeket is on a distinguished road
Default

Wow.

I've read this is a dealer only process.

Now I'm going to try this over the weekend.

2005. Same process i presume?

Thanks Dietz.
Kapeket is offline   Reply With Quote
Reply

Bookmarks

Tags
2007 equinox, bcm, won't start



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remote Start jsfb6pts 2010+ Equinox General Forum 8 02-18-2014 04:23 AM
Remote Start ptco911 2010+ Equinox Maintenance 2 12-09-2013 02:55 AM
Add Remote Start to Nox LS? nolimits76 2010+ Equinox General Forum 14 04-13-2012 08:42 PM
strange start up Z_Ghost 2010+ Equinox General Forum 9 04-18-2011 09:53 AM
Remote start- No start Z_Ghost 2010+ Equinox General Forum 3 01-15-2011 11:14 AM