Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum

Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum (http://www.chevyequinoxforum.com/)
-   05-09 Equinox Maintenance (http://www.chevyequinoxforum.com/f37/)
-   -   07 AWD Equinox Tran stuck in N, but shifter free (http://www.chevyequinoxforum.com/f37/07-awd-equinox-tran-stuck-n-but-shifter-free-2872/)

Root10 10-26-2019 03:13 PM

07 AWD Equinox Tran stuck in N, but shifter free
 
The past week or two I've noticed after driving my car, whenever I would go to put it into park the shifter would stop before passing Reverse even with the brake on and shifter button pressed in. However if I dropped the shifter back down to L then back up I could then put it in park. Problem Solved right? Nope!*

Today first thing this morning, same exact thing happens. It sticks at Reverse so I drop it down to L then as I bring it up into park the shifter continues fine into P but I notice the light on the dash and the light on the shift bezel is stuck at Neutral. However my shifter is completely free, I still have press the button on the shifter but that's it.*

I've had this happen on normal GM transmissions and its normally the bushing that connects the shift cable to the transmission shifter dry rotted, but this transmission from what I've seen is certainly not the same! Does anyone have any idea what I may be looking at here? I'm kind of at a lost. Its a 2007 Chevy Equinox LT, AWD 3.6L, with 120k miles. Any help would be a great help guys!

Root


All times are GMT -4. The time now is 10:38 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO