Window Washer Fluid Leak

VAST

New member
Joined
Aug 21, 2014
Messages
1
Reaction score
0
I just bought a 2014 GMC Terrain. I got a really good deal on it, but while test driving it I did not check to see if the window washer fluid worked. It failed the safety inspection because of this.

I went and bought some washer fluid and put it in the reservoir...no leak. But when I try and run my fluid to my front windshield the washer fluid leaks all over by the drivers side front tire. I know the pump works, but I think that the hose might be broke or disconnected.

Does anyone know what to do? How do I go about fixing this problem? Any advice would be great.
 

TheDarkKnightKnox

New member
Joined
Apr 25, 2012
Messages
268
Reaction score
0
Location
Columbus, OHIO
Well i think the first thing i would do is get under the hood and try to find where the leak is coming from. If the hose is broken i would try to find some rubber hose i could bridge the break from and some small clamps to hold it together.

If you purchased from a dealer as a certified pre-owned i would take it back and have them fix it.
 

thebluegoat

New member
Joined
Mar 31, 2015
Messages
1
Reaction score
0
If you open your hood and pop off the trim piece that covers the length of the fender there is a washer hose connection there, sounds like it's either broken or wasn't connected properly.
 

randylutz

New member
Joined
Apr 7, 2015
Messages
16
Reaction score
0
Seems like you have a hose issue. If you just purchased it, your dealer should do something abt it. I'd call them and take it back.
 
Last edited:

Members online

No members online now.
Top