engine stuttering/shaking at stop while in drive

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

timr847

New member
Joined
Aug 3, 2022
Messages
16
Reaction score
3
Hey guys this car 2013 2.4 100k+ has been a complete nightmare for me! First was timing issue so i changed out timing chains, guides, cam phasers(buy oem because the aftermarket phasers are 2 different phasers i learned that the hard way took me 2 moinths to figure out when i looked at GM parts gguide ). took off head, took apart, cleaned it and replaced the springs, valves n lifters. This POS is still stuttering/shaking while stopped. I'm beside myself i put well over $1500 into this pos and its still doing this, does anyone know why or what it could be. I replced entire timing set, redid entire top end and still doing this stuttering crap. PLEASE HELP!
 

corvairbob

Member
Joined
Oct 19, 2021
Messages
185
Reaction score
19
by any chance did you clean the TB? also is is givieng any codes yet? do this test if youhave not yet done it. when at a stop and it starts the issue try putting it into neutral. when the engien speeds up does that go away? if so the TB or the gas pedal. most likely the TB needs to be cleaned. if it continues then the plugs coild or injectores or even the high pressure fuel pump.

but you have to give us some codes. the dirty TB will not give codes for the most part. let us know n this issue below is more for upcoming issues on this topic

for all future 2nd gen tieming chain repair issues go to cloyes and get the parts. they are oem and 1/2 the price. the phasers can be 2 different one or the same. on the LEA engien they are the same, for allt he rest of the engien they are different. if after you do this work and yous till get the p0017 code more than likey the exhaust cam relutor slipped on the cam and has to be reset and staked so it will not turn again. that is quite a thread on this between me and another fella. i may be able to find that for anyone that needs to read that one. it is a long one. good luck been there done that.
 

timr847

New member
Joined
Aug 3, 2022
Messages
16
Reaction score
3
When it does do it yes it stops after putting into neutral?
TB, Throttle body?
I replaced both fuel pumps in tank and high pressure pump. Entire top end was completely redone with new parts. Thats why I'm freaking out over this. I have an employee with same type of car but 2011 n 3.6 and she said their mech. told her to put injector cleaner in there , she did and appearently it went away for hers. I had my daughter do same but really no change but maye she needs to do couple times ?

THANK YOU for response!!
 

corvairbob

Member
Joined
Oct 19, 2021
Messages
185
Reaction score
19
yes TB = throttle body. git that a try. my girls did that and when she either put it into neutral or turned on the a/c or gave it a bit of gas, that stutter went away. and like i said it could be coils plugs or injectors. the plugs and coils toss out codes a faulty injector will give a code but if it is not preforming good it may not toss a code. one way si to pull the injectors power plug one at a time to find the bad or affected cylinder and then at least you know what injector might be the issue. but before you go thru all that do like daughter did and put in some injector cleaner. i hear seafoam does good at this. and give it some time to work. than if it fal you know what youahve to do. more wrench turning. but bad injectors bad coils and plugs should be setting codes, only dirty injector may not set codes.

if the a/c or a bit more throttle or neutral at stops helps that leads to a dirty TB. good luck
 

RGonzalez

New member
Joined
Mar 14, 2023
Messages
1
Reaction score
1
I started having the same problem with my 2013 Equinox (2.4 L engine) at about 115K miles. One-owner car, never driven hard--just started failing. Turns out the engine was dry, no oil. Now I have to add a quart of oil every 1000 miles or so, to keep the car running. Defective piston rings led to excessive oil consumption, a huge problem that apparently thousands of owners were never informed about:

Turns out that I wasn't infomed either (even though GM has sent me notices about other unrelated recalls). GM Customer Care keeps giving me the runaround, even though it has already cost me $230 for diagnostic tests and now, the excessive oil consumption has now ruined the front catalytic converter. Estimated cost to replace piston rings and catalytic converter: $8200

2013 Equinox owners beware--you may have never been informed about these extended warranties ('Special Coverage Adjustments'), and it's now too late to seek help--unless a class action suit is initiated someday:
 

corvairbob

Member
Joined
Oct 19, 2021
Messages
185
Reaction score
19
did you get your engine taken care of? most of the time what happens is that issue eats away at the timeing chain and guides and most wind up with having those repaired and then rings done. because my girl complained of oil use when i did the timing i yanked out the engine thru the top, it can be done rather easy and took it down to a rebuild.
 

swisscheese

New member
Joined
Oct 4, 2016
Messages
13
Reaction score
1
I started having the same problem with my 2013 Equinox (2.4 L engine) at about 115K miles. One-owner car, never driven hard--just started failing. Turns out the engine was dry, no oil. Now I have to add a quart of oil every 1000 miles or so, to keep the car running. Defective piston rings led to excessive oil consumption, a huge problem that apparently thousands of owners were never informed about:

Turns out that I wasn't infomed either (even though GM has sent me notices about other unrelated recalls). GM Customer Care keeps giving me the runaround, even though it has already cost me $230 for diagnostic tests and now, the excessive oil consumption has now ruined the front catalytic converter. Estimated cost to replace piston rings and catalytic converter: $8200

2013 Equinox owners beware--you may have never been informed about these extended warranties ('Special Coverage Adjustments'), and it's now too late to seek help--unless a class action suit is initiated someday:
If you are using synthetic oil stop. Start using high mileage (syn blend)10-40. That should cut your oil consumption in at least half
 

corvairbob

Member
Joined
Oct 19, 2021
Messages
185
Reaction score
19
no i tried that and that did not help high mileage oil is for the seals to help maintian them due to them getting hard over thime and heat cycles in fact if you do a rebuild and new seal you do not need high mileage oil again until the engine miles get up into the 150k range. thanks
 

dtrannyman

New member
Joined
Mar 24, 2023
Messages
3
Reaction score
1
For the fellow with this initial post -
I just went through the frustration of occasional stuttering and stalling. I couldn’t understand it. My situation seemed to be remedied once I pulled the intake and cleaned the Pcv circuit. The entire circuit- not just the hole! New gaskets and install.
Perhaps this will help you.
That 2.4 is something special.
That’s for sure
 

Attachments

  • 3F39F7E6-4491-45F7-9D9C-00209F90AFF9.jpeg
    3F39F7E6-4491-45F7-9D9C-00209F90AFF9.jpeg
    173 KB · Views: 2
  • 09709183-3F35-41CC-84FD-240E4861D68D.jpeg
    09709183-3F35-41CC-84FD-240E4861D68D.jpeg
    129.9 KB · Views: 2

corvairbob

Member
Joined
Oct 19, 2021
Messages
185
Reaction score
19
one thing you can do is a retro pvc system there are a few YT on how to do it, the new equinox has put the pvc system back
 

dtrannyman

New member
Joined
Mar 24, 2023
Messages
3
Reaction score
1
I’d hope so!! Only if things stayed perfect would that ever stay working. And that’s impossible.
Glad they fixed it
 

Members online

Top