AUX stereo function not working

achtung3945

New member
I have a 2011 Equinox LT and am very happy with most everything but the Aux ("ipod connector") is not working. When I plug either an Ipod or my Iphone to the 3.5 mm jack and push the "AUX" button on the stereo I don't get any sound. I have tested the audio cable and that is not the problem. Also the USB port doesn't seem to work either. It recognizes my Iphone but won't allow me to play anything. I took this into a dealer and they said I need to order a replacement connector module as they tested the connections, they said, and everything seemed to be connected properly. So I paid for the part and they installed it and still nothing. They finally said they don't know how to fix it. So basically I have a working stereo but no AUX function to plug my Ipod into my stereo. Anyone had this before and or know what to do to fix it?

Thanks for any help!
 

rbiggers

Senior Member
I would take it to another dealer. That's a weird problem. But a dealer should for dang sure be able to figure it out and not just give up.
 

Yesimrob

New member
I hope I ran into the right discussion area here. I currently own a chevy Malibu ltz 2010 model and use a portable Sony player (has the surround feature on it-d844k). Anyhow when I hook up the line out off the CD player to the aux input on the radio and play CDs the sound is normal.
I took a 2010 chevy Equinox lt2 out for a spin today and liked the rest of the vehicle. When I tried the portable player thru the aux input I get sound but along with that is popping and hissing and even a high pitch whistle sound as the CD player is playing. At a louder volume you dont hear it as much but as the music is quieter between tracks the background whining and hissing is terrible. This does not happen on my Malibu Bose system just the high end pioneer system on the lt2. I even tried a 15 lt1 Equinox and the same problem. Anyone know if the electronics in the pioneer system can cause this? I told the salesperson the sale is on the CD player working and both of us disappointed and don't know why this would happen. After reading about iPod problems I had to put in my two cents worth. Any thoughts on this?
 
I don't have any issue with this problem but I have a android powered device and I buy good chords.

It seems that apple devices didn't work well as if they were tested on Android and not on apple.
 

Louis Larocque

New member
aux port not working

I was told also to leave it at the garage for repair.
I was wondering if just a reset, like disconnection the battery for 5 minutes would do the trick.
 

watergirl

New member
My solution

I had a similar problem with my Chevy Equinox to what was in this thread and googled to try and find the answer which led me to this page. However I didn't see HOW I ended up fixing my issue in the end listed above, so I registered just to share what I did...

My issue: My aux connected to my iPhone was working fine one day, then the next it didn't work at all. I knew it wasn't the cable because my phone pinged acknowledging that it was charging through the car. Sound was coming from my phone, but not from my Equinox's stereo. AUX on my console displayed that no input was found. I tried turning on/off the car and restarting my phone. But no luck. Tried doing both about 2-3 times. I even tried with a brand new apple cord to see if that would work. No luck. I was *this close* to taking it to the dealership, but googled once more...

I stumbled into a thread at MAC forums about this same issue and the Mac posters there suggested making sure that your iPhone was up to date. I normally keep my phone up to date so I was sure this wasn't the issue. But I checked the settings just the same and sure enough, there was a needed update. I updated my phone, then tried again in my car and BOOM! Totally worked.

Not sure how or why the two are connected, but it worked for me. Thought I'd share the fix in case this might help someone else out.
 

Members online

Top