Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Search Forums




Showing results 1 to 5 of 5
Search took 0.00 seconds.
Search: Posts Made By: scotty2666
Forum: 2010+ Equinox General Forum 12-19-2015, 09:54 AM
Replies: 10
Views: 6,274
Posted By scotty2666
solution solved replaced passenger side wheel...

solution solved replaced passenger side wheel bearing, problem went away! apparently there is a thin magnetic strip around the back of the bearing that looked to be missing small pieces from it. you...
Forum: 2010+ Equinox General Forum 12-02-2015, 06:56 PM
Replies: 10
Views: 6,274
Posted By scotty2666
I replaced both front and rear ABS sensors. the...

I replaced both front and rear ABS sensors. the rear one was VERY difficult to replace in fact the end broke off while I was extracting it from the hub, hence I had to remove the hub entirely to get...
Forum: 2010+ Equinox General Forum 12-01-2015, 07:40 AM
Replies: 10
Views: 6,274
Posted By scotty2666
I got the vehicle rescanned and the codes cleared...

I got the vehicle rescanned and the codes cleared with the scan tool at oreilleys but it came back on a mile down the road. only thing I haven't replaced are the hub bearings, and well they aren't...
Forum: 2010+ Equinox General Forum 11-30-2015, 03:20 PM
Replies: 10
Views: 6,274
Posted By scotty2666
got the codes replaced both Front and rear ABS...

got the codes replaced both Front and rear ABS sensors, issue has not gone away.
Forum: 2010+ Equinox General Forum 11-26-2015, 01:10 PM
Replies: 10
Views: 6,274
Posted By scotty2666
Stabilitrack/ ABS light on after doing new Brakes and rotors

I have a 2011 Equinox LT I replaced the pads and Rotors, now the Stabilitrack and ABS light have came on. Anyone have any idea why??? I didn't touch anything to cause this issue. Just replaced the...
Showing results 1 to 5 of 5

 
Forum Jump