Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox Maintenance

2010+ Equinox Maintenance

warning lights


This is a discussion on warning lights within the 2010+ Equinox Maintenance forums, part of the Chevy Equinox General Discussion category!
My 2010 Exuinox just had its abs and service stabilitrak warning lights come on. Anybody seen anything similar?...





Reply
 
LinkBack Thread Tools Display Modes
Old 08-30-2015, 12:48 PM   #1 (permalink)
Junior Member
 
Join Date: Aug 2015
Age: 61
Posts: 1
Rep Power: 0
mejorda is on a distinguished road
Exclamation warning lights

My 2010 Exuinox just had its abs and service stabilitrak warning lights come on. Anybody seen anything similar?
mejorda is offline   Reply With Quote
Old 08-30-2015, 09:33 PM   #2 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Originally Posted by mejorda View Post
My 2010 Exuinox just had its abs and service stabilitrak warning lights come on. Anybody seen anything similar?

I did and there were many things that it was suggesting to fix on other forums and I tried just about everything until I finally found the fix.

I found a TSB that I can't seem to find now for the life of me but it was alluding to the speed sensors thats found on the back side of the hub/bearing assembly. The TSB was for brake dust or other debris to accumulate on this ring, once you clean it off, it should fix problem. Once you look at the back side of the hub, you will see the internal splines of the hub. Just outside of that is a ring that might appear plastic/nylon. Clean that ring with detergent like dish soup and not to use any heavy degreasers. If this does not fix the issue at the point they recommend replacing the hub.

When I did mine, I hooked up a scanner so it told me exactly which wheel it was. I was about to disassemble the entire hub after removing the wheel, brakes, ect. But all I had to do was look on the back side of the hub from under the vehicle and I used my air compressor to shoot air at it and a cloud of debris came off of that ring/speed sensor.
dietz4ibanez is offline   Reply With Quote
Old 09-02-2015, 07:02 PM   #3 (permalink)
Junior Member
 
Panoramic PEI's Avatar
 
Join Date: Sep 2015
Location: Prince Edward Island, Canada
Posts: 5
Rep Power: 0
Panoramic PEI is on a distinguished road
Default

Verify the Fuses first, there are several, that was my experience for the fix.
Refer to the Owner's Manual for the location of these fuses.
Panoramic PEI is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
LED tail/stop lights? nuster46506 2010+ Equinox General Forum 1 06-22-2015 10:07 AM
Inter Lights: auto shutoff feature? Stinger 2010+ Equinox General Forum 1 11-20-2014 12:36 PM
Lets see those Lights! dietz4ibanez Exterior Modifications 37 11-12-2014 11:36 AM
Factory Fog Lights Georgia Nox Exterior Modifications 1 10-25-2013 08:05 PM
Equinox Tail Lights EQJUNIOR Exterior Modifications 3 12-23-2012 03:13 AM