Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox Maintenance

2010+ Equinox Maintenance

Stabil Trac System


This is a discussion on Stabil Trac System within the 2010+ Equinox Maintenance forums, part of the Chevy Equinox General Discussion category!
My "Service Stabil Trac" light has come on twice in the past month. On both occassions, it went out after ...





Reply
 
LinkBack Thread Tools Display Modes
Old 11-14-2013, 10:29 AM   #1 (permalink)
Junior Member
 
Join Date: Jul 2011
Location: Edmonton, AB
Posts: 9
Rep Power: 0
Ken Rosey is on a distinguished road
Default Stabil Trac System

My "Service Stabil Trac" light has come on twice in the past month. On both occassions, it went out after re-starting the vehicle. I spoke to the dealer and was told the light has to be on for a diagnoses of the problem. Even though the light is now off, I'm taking it in to the dealer. Does anyone know what some common problems are, the fix, and what's involved with the "service"?

Thanks,
Ken
Ken Rosey is offline   Reply With Quote
Old 11-14-2013, 08:54 PM   #2 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

I haven't got a clue on this one. It will be interesting to learn what might be triggering this! Keep us updated if you can!
dietz4ibanez is offline   Reply With Quote
Old 02-04-2014, 08:36 PM   #3 (permalink)
Junior Member
 
Join Date: Feb 2014
Posts: 1
Rep Power: 0
TheDeuce is on a distinguished road
Default Stabilitrak

I don't know if this applies, however I have similar problem with my 2006 Trailblazer with Stabilitrak. It was determined on those vehicles that sometimes during cold weather (less than 50 with my truck), if you park the front wheels at an angle, the sensors in the front wheels will not have a good connection upon startup, and will report a fault. If the wheels are parked straight, the system should be fine. I've noticed that as soon as I start moving, if the light comes on, I stop the car, restart it, and then keep going. The light should be off by then. Its just become habit to remember to park the car with the wheels straight and I usually don't have to worry about it. Hope this helps!
TheDeuce is offline   Reply With Quote
Old 02-12-2014, 11:49 AM   #4 (permalink)
Junior Member
 
Join Date: Oct 2013
Location: Chicago
Posts: 14
Rep Power: 0
DVB1 is on a distinguished road
Default

I agree w/ deuce, we had this happen last month, several subzero days and my wife was called off work because of the weather so the EQ sat through those days. When she went back to work, on the way home she receive the "Service Stabil Trac" and lost power steering! The next morning everything was fine. Not sure how the wheels were but with a few days of snow and -4 to -12 days and the EQ not moving, I can see weather being the cause of this.
__________________
08 Equinox LT 3.4 V6
06 Jeep WK LTD 4.7 (DD)
DVB1 is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with Theft Deterrent System JayLT484 05-09 Equinox Maintenance 1 07-06-2013 10:33 PM
GM MyLink navigation system johns4949 2010+ Equinox General Forum 4 11-21-2011 08:29 AM