Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox Maintenance

2010+ Equinox Maintenance

Rough Start then smooth


This is a discussion on Rough Start then smooth within the 2010+ Equinox Maintenance forums, part of the Chevy Equinox General Discussion category!
I have a 2013 LTZ. Starting this week...car starts fine but idles rough for about 15 seconds then smooths out ...





Reply
 
LinkBack Thread Tools Display Modes
Old 03-07-2017, 08:35 PM   #1 (permalink)
Junior Member
 
Join Date: Mar 2017
Posts: 1
Rep Power: 0
Sparty is on a distinguished road
Default Rough Start then smooth

I have a 2013 LTZ. Starting this week...car starts fine but idles rough for about 15 seconds then smooths out and runs normally. Something simple?
Sparty is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle that won't go away... RevStuie 2010+ Equinox Maintenance 3 07-20-2018 06:55 PM
Rough Idle on 2011 Equinox Newtodanox 2010+ Equinox General Forum 2 01-31-2017 11:09 AM
06 equinox rough idle at startup only [email protected] 05-09 Equinox General Forum 5 09-10-2012 03:45 PM
2010 nox rough idle jherman 2010+ Equinox General Forum 4 04-13-2012 11:40 PM
Remote start- No start Z_Ghost 2010+ Equinox General Forum 3 01-15-2011 11:14 AM