Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox Maintenance

2010+ Equinox Maintenance

Grinding Noise upon Braking


This is a discussion on Grinding Noise upon Braking within the 2010+ Equinox Maintenance forums, part of the Chevy Equinox General Discussion category!
Hi all, i attempted to search for a thread that is similar to my situation but couldn't find anything. Any ...





Reply
 
LinkBack Thread Tools Display Modes
Old 09-11-2015, 11:16 AM   #1 (permalink)
Junior Member
 
Join Date: Sep 2015
Age: 41
Posts: 1
Rep Power: 0
abdraftsman is on a distinguished road
Default Grinding Noise upon Braking

Hi all, i attempted to search for a thread that is similar to my situation but couldn't find anything. Any help is greatly appreciated.

I just did brakes and rotors all the way around my 2011 equinox awd v6. Afterward i am getting a grinding noise as i brake. The noise is intermittent and when it happens it is always just as i'm almost stopped. It is coming from the front but can't tell which side. I get no ABS lights and it doesn't really feel like anything to do with ABS. Sometimes i can release pressure on the pedal slightly and reapply pressure and the grinding will go away.

I've taken both sides apart again twice to check for problems and found nothing rubbing or scraping. Each time i've put everything back together the noise goes away for a few days before returning.

I've also put both front wheels in the air, started the truck and tried to simulate the grinding/braking issue but cannot get it to do it.

I'm about to book an appointment with the dealer to have them figure it out but am hoping someone here has some ideas first.

Thanks!
abdraftsman is offline   Reply With Quote
Old 09-11-2015, 08:52 PM   #2 (permalink)
Senior Member
 
mswerb's Avatar
 
Join Date: Aug 2012
Location: Cleveland, Ohio
Age: 46
Posts: 197
Rep Power: 8
mswerb is on a distinguished road
Default

I would take it to and independent brake shop before the dealer. Unless you like being bent over backwards.
__________________
2007 Granite Gray Metallic Equinox
mswerb is offline   Reply With Quote
Old 09-12-2015, 04:08 AM   #3 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

It could be the new pads on old rotors. I've had that issue with mine, starting to wonder if I should have them turned again in attempts to get rid of the noise. Figuratively, the old pads and rotors will grove to each other as wear persists. Typically when you add new pads to a previously warn rotor they aren't 100% mates so you can get some pretty bad break noises.
dietz4ibanez is offline   Reply With Quote
Old 02-09-2016, 10:10 AM   #4 (permalink)
Junior Member
 
Join Date: Feb 2016
Age: 24
Posts: 3
Rep Power: 0
tlwilliams is on a distinguished road
Default

What size tires do you have? i am looking for a new set. I went to a local tire place and they said 22'' couldnt fit on my equniox
tlwilliams is offline   Reply With Quote
Old 02-09-2016, 10:11 AM   #5 (permalink)
Junior Member
 
Join Date: Feb 2016
Age: 24
Posts: 3
Rep Power: 0
tlwilliams is on a distinguished road
Default

Did you ever figure out what was the cause. i am having the SAME issues with my 2012 equniox
tlwilliams is offline   Reply With Quote
Old 02-15-2016, 10:54 PM   #6 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

My wheels are 20's, I'm sure 22's would fir with a lower profile tire.

Sorry for the thread jack.

I probably would have taken those rotors back. Sounds like they weren't surfaced properly.


It may go away as they get broken in with the new pads but they shouldn't be making any noise.
dietz4ibanez is offline   Reply With Quote
Old 02-22-2017, 10:22 AM   #7 (permalink)
Junior Member
 
Join Date: Feb 2017
Posts: 1
Rep Power: 0
Ilbronco is on a distinguished road
Default Same Issue:

Originally Posted by abdraftsman View Post
Hi all, i attempted to search for a thread that is similar to my situation but couldn't find anything. Any help is greatly appreciated.

I just did brakes and rotors all the way around my 2011 equinox awd v6. Afterward i am getting a grinding noise as i brake. The noise is intermittent and when it happens it is always just as i'm almost stopped. It is coming from the front but can't tell which side. I get no ABS lights and it doesn't really feel like anything to do with ABS. Sometimes i can release pressure on the pedal slightly and reapply pressure and the grinding will go away.

I've taken both sides apart again twice to check for problems and found nothing rubbing or scraping. Each time i've put everything back together the noise goes away for a few days before returning.

I've also put both front wheels in the air, started the truck and tried to simulate the grinding/braking issue but cannot get it to do it.

I'm about to book an appointment with the dealer to have them figure it out but am hoping someone here has some ideas first.

Thanks!
I am having the same issue. Just recently had brakes done. Same noise only when braking from 5-0 mph. It is coming from the front drivers side. From outside it does not sound like a grind but more like a rubbing noise.

Has anyone determined the root cause. Could it be the CV joint wearing out or a bearing wearing out? It kind of has me stumped.

Any help would be appreciated.

Thanks
Ilbronco is offline   Reply With Quote
Old 09-27-2017, 06:22 PM   #8 (permalink)
Junior Member
 
Join Date: Sep 2017
Age: 28
Posts: 1
Rep Power: 0
Derty2009 is on a distinguished road
Default

I see this is an older thread, but has anyone resolved this issue? It has me stumped as well.
Derty2009 is offline   Reply With Quote
Old 07-23-2018, 07:30 PM   #9 (permalink)
Junior Member
 
Join Date: Jul 2018
Posts: 1
Rep Power: 0
InnerPulseEnergy is on a distinguished road
Default

I currently have my 13' Equinox in the shop for this exact issue, the bearing was replaced and it was not the issue, pads and rotors have been checked and are also fine, however the shop says at first sound it almost is as if the wrong breaking system was put onto the vehical, reading this it seems to be a serious issue... has anyone had this issue resolved?
InnerPulseEnergy is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Noise On Startup - A/C Issue? BVK1201 2010+ Equinox General Forum 4 01-17-2017 02:43 PM
2006 equinox grinding noise in rear Artie Site Comments, Suggestions and Questions 2 12-15-2015 06:08 AM
Rattle Noise Front End BionicBo 05-09 Equinox Maintenance 4 09-10-2015 08:47 AM
strange noise when awd activates chaz34racing 05-09 Equinox Maintenance 0 10-16-2013 09:43 PM
ABS brake noise,when brakes are applied john2882 Suspension and Brakes 1 10-15-2013 08:09 PM