Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox Maintenance

2010+ Equinox Maintenance

2014 4Cyl Clicking on cold starts


This is a discussion on 2014 4Cyl Clicking on cold starts within the 2010+ Equinox Maintenance forums, part of the Chevy Equinox General Discussion category!
My 14 Equinox has a loud clicking sound on startups that are cold and goes away after about 10 minutes, ...





Reply
 
LinkBack Thread Tools Display Modes
Old 10-31-2016, 11:27 AM   #1 (permalink)
Junior Member
 
Join Date: Oct 2016
Posts: 1
Rep Power: 0
kenpoed is on a distinguished road
Default 2014 4Cyl Clicking on cold starts

My 14 Equinox has a loud clicking sound on startups that are cold and goes away after about 10 minutes, but it is loud.

Only 17K miles on it and when I took it to the dealer they replaced the high pressure fuel pump. It was fine for 3 weeks and now is sounding worse than ever.

Anyone know what this could be? Frustrating to have this with a Certified pre owned I have only driven a thousand miles. THinking about getting rid of it.

Help please!
kenpoed is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant Temp Gage pegs cold Trebor 05-09 Equinox Maintenance 5 11-07-2018 07:54 AM
2010 Chevy Equinox I4 strange AC issue - blows cold out of driver side only AllensaurusRex 2010+ Equinox General Forum 0 05-09-2016 12:56 PM
Whining Noise starts around 20mph and gets louder refderek 05-09 Equinox General Forum 6 03-25-2016 01:44 PM
2014 lt2 tpm New Member Introduction 1 08-28-2015 08:29 PM
Cold weather Z_Ghost The Lounge 5 01-14-2011 06:10 AM