Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox Maintenance

2010+ Equinox Maintenance

2013 equinox outside temp monitor


This is a discussion on 2013 equinox outside temp monitor within the 2010+ Equinox Maintenance forums, part of the Chevy Equinox General Discussion category!
Since the day I got the equinox, this outside temp monitor did not function properly. I mentioned it once while ...





Reply
 
LinkBack Thread Tools Display Modes
Old 06-24-2014, 04:00 PM   #1 (permalink)
Junior Member
 
Join Date: Jun 2014
Posts: 1
Rep Power: 0
tomas161 is on a distinguished road
Default 2013 equinox outside temp monitor

Since the day I got the equinox, this outside temp monitor did not function properly. I mentioned it once while having service, but was told it would be ok. Next time I made a specific apt to have it checked, and same thing, it will adjust automatically, etc... It has not. It is not a big thing, but it should be working. I had a 2002 olds van for 12 years and the outside display was always working, never a problem.. just a bit irritating. No complaints on the total vehicle or performance.
tomas161 is offline   Reply With Quote
Old 06-25-2014, 06:45 AM   #2 (permalink)
Senior Member
 
jsfb6pts's Avatar
 
Join Date: Apr 2011
Location: Petoskey ,Michigan
Posts: 208
Rep Power: 9
jsfb6pts is on a distinguished road
Default

I had a 2011 ,never had a problem .I now have a 2014 no issues with that either .
jsfb6pts is offline   Reply With Quote
Old 05-17-2015, 01:23 PM   #3 (permalink)
Junior Member
 
Join Date: May 2015
Posts: 1
Rep Power: 0
mikeCsix is on a distinguished road
Default

The outside temp monitor is located on the passenger side of the vehicle, just in front of the radiator and behind the bumper it is mounted on a bracket to sample air prior to the radiator. It has a weather proof connector, if the sensor isn't functioning, either there is a broken wire in the wiring harness, the sensor has failed or the connection is only partially made. Since the connector is weather proof, it can appear to be connected when in fact it isn't. I would pull the connector out, inspect for water or damage, then plug it back together making sure it is fully seated.

The sensor does not work in a 'gradual' way, it either works or it doesn't. My car was in the dealer for some air conditioning work, they had to pull the sensor for some reason and neglected to fully seat the sensor connector upon reassembly. We noticed it not working when we arrived home from the dealer. I called the dealer for assistance in finding the sensor, while awaiting call-back, I went on the internet, found out where the sensor was located, went out to the car, found the connector not fully seated, re-connected the sensor, turned the car on and it was functioning normally. No driving, no waiting, it either works or it doesn't.
mikeCsix is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Temp guage hot when cars not! Roslyn 05-09 Equinox Maintenance 2 08-07-2014 01:19 PM
Equinox A/C air output temp Darwin 2010+ Equinox Maintenance 1 06-26-2014 09:25 PM
LCD Monitor Doubles Songs Zachary Audio & Electronics 1 06-05-2014 09:30 PM
Tire Pressure Monitor Starfire 2010+ Equinox Maintenance 1 04-28-2014 09:08 AM
2013 New Equinox chucko 2010+ Equinox General Forum 2 03-08-2013 09:53 PM