Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

Sluggish Starting and Clomate Control Issues


This is a discussion on Sluggish Starting and Clomate Control Issues within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
Two things just started happening with our 2014 Equinox (24k miles). We have an appointment at the dealer on Monday, ...





Reply
 
LinkBack Thread Tools Display Modes
Old 11-14-2015, 03:48 PM   #1 (permalink)
Junior Member
 
Join Date: Nov 2015
Posts: 1
Rep Power: 0
Erieshores is on a distinguished road
Default Sluggish Starting and Clomate Control Issues

Two things just started happening with our 2014 Equinox (24k miles). We have an appointment at the dealer on Monday, but always looking for some guidance on what the issue may be.

When we start the car it starts, but the starter seems sluggish. It's hard to describe other than being sluggish. It usually starts it just sounds like it is either bogged down or not enough juice in the battery.

About every other time when we start the car the climate control does not work. You can click the on/off button and nothing lights up on the center console where you select auto, defrost, etc. You can adjust the temperature and nothing displays on th navigation screen. It just does not work. If you turn off the car and restart the car the climate control system usually works then.

Any ideas?

Not great for a car with 24k miles...

Last edited by Erieshores; 11-14-2015 at 04:31 PM.
Erieshores is offline   Reply With Quote
Old 01-04-2016, 08:54 PM   #2 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Hopefully it was just a battery. What did they end up saying?
dietz4ibanez is offline   Reply With Quote
Reply

Bookmarks

Tags
climate control, sluggish, starter



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 Chevy Equinox w/ intermittent starting issues. jtwicked82 2010+ Equinox Maintenance 1 09-26-2015 11:10 PM
starting problems dan112 2010+ Equinox Maintenance 4 09-25-2015 11:09 PM
abs traction control light on jman3624 2010+ Equinox General Forum 0 09-22-2014 08:19 PM
Starting problems, gas smell, shifting issues.. Helene74 2010+ Equinox Maintenance 13 05-22-2012 08:25 AM
Remote outside mirror switch and control jsfb6pts Interior Modifications 9 08-08-2011 09:20 AM