Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

HAS GM FIXED THE 2.4 (in the Equinox) ?


This is a discussion on HAS GM FIXED THE 2.4 (in the Equinox) ? within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
Hi Folks, does anyone know if 2.4 engine issues still exist in newer Equinox models ? I am referring to ...





Reply
 
LinkBack Thread Tools Display Modes
Old 05-28-2017, 09:16 PM   #1 (permalink)
Junior Member
 
Join Date: May 2017
Posts: 1
Rep Power: 0
POPFIXR is on a distinguished road
Default HAS GM FIXED THE 2.4 (in the Equinox) ?

Hi Folks, does anyone know if 2.4 engine issues still exist in newer Equinox models ? I am referring to problems such as oil consumption, bad timing chains/tensioners and any other known issues. I am considering buying one 2014 or newer. Thanks for your help....
POPFIXR is offline   Reply With Quote
Old 06-01-2017, 06:50 PM   #2 (permalink)
Junior Member
 
Join Date: Jun 2017
Location: Alabama
Posts: 2
Rep Power: 0
Richard is on a distinguished road
Default

As far as I know they have not, fix one another pops up. To much car not enough engine. I just traded my 2012 2.4 for a 2015 with the V6 now it can merge onto the interstate.
Richard is offline   Reply With Quote
Old 06-08-2017, 10:31 AM   #3 (permalink)
Junior Member
 
Join Date: Jun 2017
Location: Kansas City, MO
Age: 36
Posts: 3
Rep Power: 0
ilyk2ski is on a distinguished road
Default

Yes from what ive read up on it has been fixed from 2014 and up. The 2.4 also does just fine merging onto the hwy also. I do it everyday and never have problems. Use the on ramp for what it's purpose is for.....accelerating up to hwy speeds.
ilyk2ski is offline   Reply With Quote
Old 06-15-2017, 07:20 AM   #4 (permalink)
Junior Member
 
Join Date: Jun 2016
Location: Central Nova Scotia
Age: 70
Posts: 10
Rep Power: 0
Relic49 is on a distinguished road
Default

We have a 2016 with the 2.4, and it just runs GREAT. No problems with on ramps, and I'm used to driving a P/U with 5.3.
Relic49 is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
I broke the Lumbar... *UPDATE* Fixed. (See post #9) dietz4ibanez Interior Modifications 19 01-04-2016 11:03 AM
2012 equinox transmission fixed peavyxs 2010+ Equinox General Forum 0 06-10-2015 09:03 PM