Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

ECO mode


This is a discussion on ECO mode within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
Does anyone drive around town with the eco mode on? I have a 2010 nox and in the eco mode ...





Reply
 
LinkBack Thread Tools Display Modes
Old 03-03-2013, 12:32 AM   #1 (permalink)
Junior Member
 
Join Date: Sep 2011
Age: 47
Posts: 11
Rep Power: 0
jherman is on a distinguished road
Default ECO mode

Does anyone drive around town with the eco mode on? I have a 2010 nox and in the eco mode it idles really rough at stop lights and when it is in park. When eco mode is off it idles a lot better. Just wondering if this is normal or if I should have mine looked at?
jherman is offline   Reply With Quote
Old 03-27-2013, 09:54 AM   #2 (permalink)
Junior Member
 
Join Date: Mar 2013
Posts: 1
Rep Power: 0
TurboRaddo is on a distinguished road
Default

I have a 2013 1LT I got a week ago. I have left it in ECO mode for driving around town. No issues with idle. I have also read a bunch of posts from other people that leave it in ECO mode at all times.
TurboRaddo is offline   Reply With Quote
Old 03-28-2013, 06:52 PM   #3 (permalink)
Senior Member
 
2010BlkGraniteNox's Avatar
 
Join Date: Jul 2010
Location: Viera, FL
Posts: 398
Rep Power: 10
2010BlkGraniteNox is on a distinguished road
Default

Originally Posted by jherman View Post
Does anyone drive around town with the eco mode on? I have a 2010 nox and in the eco mode it idles really rough at stop lights and when it is in park. When eco mode is off it idles a lot better. Just wondering if this is normal or if I should have mine looked at?
ECO mode has to do with the TC lock-up, and idle speed (since TC is locked up), with minor changes in shift points. I personally drove it with ECO off because I spent 95% of my time on the highway with cruise on.

ECO=+1 mpg according to GM around town IIRC. To me it was not worth that.
__________________
2010 Black Granite Equnox 2LT
HFV6/Jet Leather/Tow/Cargo/PwrLift *retired..great setup!*
2010 Silvermist Equinox 1LT *retired 27mpg avg*

2012 Silver Imapala LT 3.6 VVT SIDI 304HP (work car)
2012 Audi A3 Sportback Premium Plus TDI (current)
2010BlkGraniteNox is offline   Reply With Quote
Old 04-07-2013, 09:47 AM   #4 (permalink)
Junior Member
 
Join Date: Apr 2013
Posts: 2
Rep Power: 0
ferg is on a distinguished road
Default

I have this same problem when at stop lights my idling go's really low and is very rough. i have 120 K on atm. I have been thinking about having it look at but, do not want to get into chasing a problem in the computer.
ferg is offline   Reply With Quote
Old 05-08-2013, 08:00 PM   #5 (permalink)
Junior Member
 
Join Date: Mar 2013
Location: NH
Posts: 1
Rep Power: 0
JPNNH is on a distinguished road
Default

I started driving with ECO off too...Drives so much better & 1 mpg not worth it to me
JPNNH is offline   Reply With Quote
Old 05-25-2013, 09:18 AM   #6 (permalink)
Junior Member
 
Join Date: Dec 2012
Age: 42
Posts: 16
Rep Power: 0
masijc is on a distinguished road
Default Re: ECO mode

I recently stopped using ECO mode and noticed a night and day difference with the idle at stops. 80% of my driving is on the highway. I will give an update on mpg performance in a week or so.

Sent from my Nexus 7 using Tapatalk 2
masijc is offline   Reply With Quote
Old 06-30-2013, 09:23 PM   #7 (permalink)
Junior Member
 
Join Date: Dec 2012
Age: 42
Posts: 16
Rep Power: 0
masijc is on a distinguished road
Default Re: ECO mode

After a month of normal driving with the ECO mode off I am actually getting better fuel economy. Went from 23.6 to 23.8mpg!

Sent from my Nexus 7 using Tapatalk 2
masijc is offline   Reply With Quote
Old 07-12-2013, 11:46 PM   #8 (permalink)
Junior Member
 
Join Date: Sep 2011
Age: 47
Posts: 11
Rep Power: 0
jherman is on a distinguished road
Default

Thanks for your input. When I had it in for the recall on the oil monitoring system the dealership adjusted something in the computer and it seems a little better. It seems like it idles better in eco now but a little worse in regular driving mode. The adjustment did not do anything for the idle when you first start it in the mourning. The idle jumps all over the place. I don't know if I have ever had a car that acts like this when you first start it up.
jherman is offline   Reply With Quote
Old 09-21-2013, 11:44 PM   #9 (permalink)
rob
Junior Member
 
Join Date: Apr 2012
Posts: 5
Rep Power: 0
rob is on a distinguished road
Default

I had a 2010 that had this rough idle that showed up only when stopped or sitting at traffic lights. It would come and go then eventually got so bad that the car wanted to stall. The dealership kept saying it was nothing and I kept pressing. In the end it had nothing to do with the eco, the dealership replaced the fuel pump and the problem was gone. My brother also had a 2010 and it ended up with the same problem.
rob is offline   Reply With Quote
Old 09-24-2013, 12:03 AM   #10 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 37
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Originally Posted by rob View Post
I had a 2010 that had this rough idle that showed up only when stopped or sitting at traffic lights. It would come and go then eventually got so bad that the car wanted to stall. The dealership kept saying it was nothing and I kept pressing. In the end it had nothing to do with the eco, the dealership replaced the fuel pump and the problem was gone. My brother also had a 2010 and it ended up with the same problem.
Sorry that you had that issue! Glad that they got it fixed for now!
dietz4ibanez is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On