Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

Backup camera stuck on display


This is a discussion on Backup camera stuck on display within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
...





Reply
 
LinkBack Thread Tools Display Modes
Old 03-06-2018, 09:58 PM   #1 (permalink)
Junior Member
 
Join Date: Mar 2018
Age: 31
Posts: 1
Rep Power: 0
amancini is on a distinguished road
Default Backup camera stuck on display

Hoping someone can help me out. I got in my car to leave work, backed out of my spot and got about 2 min down the road when I noticed the display was black and had the “check surroundings for safety” message as if it was in reverse. Funny enough, when my car is in park the reverse camera kicks in. In any other setting (drive, neutral or manual) it goes back to a black screen and says “check surroundings......”.

Any suggestions?
amancini is offline   Reply With Quote
Old 03-06-2018, 10:31 PM   #2 (permalink)
Member
 
Join Date: Feb 2017
Age: 34
Posts: 50
Rep Power: 3
kastner03 is on a distinguished road
Default

Originally Posted by amancini View Post
Hoping someone can help me out. I got in my car to leave work, backed out of my spot and got about 2 min down the road when I noticed the display was black and had the “check surroundings for safety” message as if it was in reverse. Funny enough, when my car is in park the reverse camera kicks in. In any other setting (drive, neutral or manual) it goes back to a black screen and says “check surroundings......”.



Any suggestions?


what year is it ?


Sent from my iPhone using Tapatalk
kastner03 is offline   Reply With Quote
Old 03-07-2018, 12:17 AM   #3 (permalink)
Member
 
Join Date: Feb 2017
Age: 34
Posts: 50
Rep Power: 3
kastner03 is on a distinguished road
Default

Originally Posted by kastner03 View Post
what year is it ?


Sent from my iPhone using Tapatalk


check ur reverse lights
when i first got my 2018 i tried some led backup lights and it did that for some reason it needs to see resistance from either a halogen bulb or leds with resistors built in. the equinox doesn’t have a bulb out indicator but this is supposedly part of the system that onstar uses to notify you of a bulb is burned out via email (if you have a subscription)


Sent from my iPhone using Tapatalk
kastner03 is offline   Reply With Quote
Old 05-08-2019, 07:19 PM   #4 (permalink)
Junior Member
 
Join Date: May 2019
Posts: 2
Rep Power: 0
caddy96sts is on a distinguished road
Default

Can anyone elaborate on this situation? I installed Diode Dynamics LED backup lights, the same units used flawelessly on two other vehicles. On the 2018 Equinox, my backup camera is now on all the time (switching to front camera when in drive).

Thanks in advance!
caddy96sts is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2016 Backup Camera with no audible alert Jacksola88 2010+ Equinox General Forum 1 01-07-2017 10:57 AM
Backup Camera IAEquinox 05-09 Equinox General Forum 6 06-01-2014 05:10 PM
Rear liftgate panel removal for backup camera install-2005 Equinox hurnik 05-09 Equinox General Forum 3 06-01-2014 04:53 PM
Upgrade 2014 LS to MyLink Radio? Backup Camera? HarvesterOfBeer Audio & Electronics 0 03-16-2014 08:13 PM
Radio display and mileage display not working Pbrenz 05-09 Equinox General Forum 0 06-02-2013 08:40 PM