Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

2018 Equinox Heater Blower Issue


This is a discussion on 2018 Equinox Heater Blower Issue within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
...





Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 11-05-2017, 01:59 AM   #1 (permalink)
Junior Member
 
Join Date: Oct 2017
Posts: 6
Rep Power: 0
TessaNorth is on a distinguished road
Default 2018 Equinox Heater Blower Issue

Iíve noticed that when I remote start my vehicle, my fan does not kick in. My climate control is manual (dials) Hereís what Iíve tried so far to see if it kicks in, none of these methods worked:
-starting with both the remote and app.
-starting with the Dan speed at medium and low
-running remote start for 20 mins instead of 10
-remote start at -4c
-remote start at -20c
-remote start after driving for 20 mins


The owners manual says it should run at the settings it was set at when it gets turned off. There is nothing in my touch screen vehicle comfort or climate control settings and nothing in my dash controls.

Dealership is at a loss, no clue whatís happening.

Given its winter and I live in Northern Alberta, would be nice to have the fan defrost my windshield!
TessaNorth is offline   Reply With Quote
Old 11-11-2017, 06:13 AM   #2 (permalink)
Senior Member
 
jsfb6pts's Avatar
 
Join Date: Apr 2011
Location: Petoskey ,Michigan
Posts: 208
Rep Power: 7
jsfb6pts is on a distinguished road
Default

Mine does the same thing ,just finding out because it just got cold here .Air worked fine last summer .I have been experimenting the past few days,turned up the fan and the temps ( dual zone ) max and it did work
Other thing I noticed is a high pitch whine from the blower/fan motor @ low speed ,radio needs to be low or off to hear it .
jsfb6pts is offline   Reply With Quote
Old 11-11-2017, 10:36 PM   #3 (permalink)
Junior Member
 
Join Date: Nov 2017
Posts: 4
Rep Power: 0
Pauline is on a distinguished road
Default

I have the same issue. Going to see dealer who sold me the car. Isn't this the whole reason for remote start to get into a warm car! Very disappointed
gpart likes this.
Pauline is offline   Reply With Quote
Old 11-12-2017, 06:26 AM   #4 (permalink)
Senior Member
 
jsfb6pts's Avatar
 
Join Date: Apr 2011
Location: Petoskey ,Michigan
Posts: 208
Rep Power: 7
jsfb6pts is on a distinguished road
Default

Mine works when I turn the fan on high and the temp all the way up .
Do you also have that high pitch whine ?
jsfb6pts is offline   Reply With Quote
Old 11-15-2017, 10:09 AM   #5 (permalink)
Junior Member
 
Join Date: Nov 2017
Posts: 4
Rep Power: 0
Pcrecord is on a distinguished road
Default

I also have the ISSUE and will try to put everything to max. But I'm sure it's a software issue...
If they can do auto defrost, it shouldn't be a problem...
Pcrecord is offline   Reply With Quote
Old 11-15-2017, 09:14 PM   #6 (permalink)
Junior Member
 
Join Date: Nov 2017
Posts: 4
Rep Power: 0
Pauline is on a distinguished road
Default

Tried putting fan on high the night before..nothing. have my dealership looking into it. Hopefully they will find an answer.
Pauline is offline   Reply With Quote
Old 11-17-2017, 10:59 AM   #7 (permalink)
Member
 
Join Date: Apr 2017
Posts: 54
Rep Power: 1
gpart is on a distinguished road
Default

I checked mine via remote start on two occasions over 2 separate days. There don't appear to be any issues with the blower and settings in mine, as far as I can tell.

"Auto" settings turn on fan (I've got mine set to low) and turns on the rear auto defrost (I set this in the "Settings" under "Vehicle"), even if the rear window doesn't have frost on it (I'm guessing it's all related to the temperature the system perceives).

I don't know if it matters but mine is an early build and purchased it in mid-April.
__________________
2018 Equinox
1.5L AWD Premier
"Sun, Sound & Nav. Pkg."
gpart is offline   Reply With Quote
Old 11-18-2017, 06:56 AM   #8 (permalink)
Senior Member
 
jsfb6pts's Avatar
 
Join Date: Apr 2011
Location: Petoskey ,Michigan
Posts: 208
Rep Power: 7
jsfb6pts is on a distinguished road
Default

My rear defrost come on with the remote start also .
Mine was built the 2nd day of production . 1/10/17 Ordered in November of 16 ,was not able to take delivery until March because of quarantine
jsfb6pts is offline   Reply With Quote
Old 11-18-2017, 08:23 AM   #9 (permalink)
Junior Member
 
Join Date: Nov 2017
Posts: 4
Rep Power: 0
Pauline is on a distinguished road
Default

The last two replies...do u two have a 2018 equinox LT? Yes funny how rear defogger works! Still waiting to hear from my dealer.
Pauline is offline   Reply With Quote
Old 11-20-2017, 10:27 AM   #10 (permalink)
Junior Member
 
Join Date: Nov 2017
Posts: 4
Rep Power: 0
Pcrecord is on a distinguished road
Default

I also have the issue, the heated seat and rear defrost works but not the fan/heat
This happens below 7c and it works when temperature is higher. I tried putting everything to full and all other suggestions.
I called my dealer which said they received a note to not work on this trouble because GM is working on an update for the computer.
This is very unfortunate but I guess we will have to wait.
I have an appointment for my tires in 2 weeks and hope they will get it before then.
TessaNorth likes this.
Pcrecord is offline   Reply With Quote
Old 11-21-2017, 09:37 PM   #11 (permalink)
Junior Member
 
Join Date: Oct 2017
Posts: 6
Rep Power: 0
TessaNorth is on a distinguished road
Default

Yes it’s very disappointing. The first time I ever have had command start and I still need to go outside and start my car. Chev corporate customer service replied to a Facebook message I sent regarding th issue and they’re looking into it and contacting the dealer.
TessaNorth is offline   Reply With Quote
Old 11-21-2017, 09:39 PM   #12 (permalink)
Junior Member
 
Join Date: Oct 2017
Posts: 6
Rep Power: 0
TessaNorth is on a distinguished road
Default

Yes. 2018 LT
TessaNorth is offline   Reply With Quote
Old 11-21-2017, 09:39 PM   #13 (permalink)
Junior Member
 
Join Date: Oct 2017
Posts: 6
Rep Power: 0
TessaNorth is on a distinguished road
Default

No high pitched whine at all.
TessaNorth is offline   Reply With Quote
Old 11-27-2017, 06:17 AM   #14 (permalink)
Senior Member
 
jsfb6pts's Avatar
 
Join Date: Apr 2011
Location: Petoskey ,Michigan
Posts: 208
Rep Power: 7
jsfb6pts is on a distinguished road
Default

Originally Posted by Pauline View Post
The last two replies...do u two have a 2018 equinox LT? Yes funny how rear defogger works! Still waiting to hear from my dealer.
Yes, I have an LT
jsfb6pts is offline   Reply With Quote
Old 12-06-2017, 04:40 PM   #15 (permalink)
Junior Member
 
Join Date: Nov 2017
Posts: 4
Rep Power: 0
Pcrecord is on a distinguished road
Default

Ok just for those like me who are still waiting ;
Last weekend, I went to the dealer and they did 3 system updates available form GM and it didn't fix the problem. The dealer will contact head office and report the problems still exist.
Again, fans remote start work when outside temperature is higher then 7 degrees but won't when temp is lower...
Pcrecord is offline   Reply With Quote
Reply

Bookmarks

Tags
2018 hvac, heater motor, remote start heat



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2018 Display Brightness issue Aheckm 2010+ Equinox General Forum 4 02-17-2018 06:16 PM
Heater Cores from RockAuto.com! RockAuto RockAuto 0 10-30-2017 12:06 PM
2009 Equinox seat heater med1881 2010+ Equinox Maintenance 0 01-27-2017 02:13 PM
Burnt blower motor control switch ! Help! Youtube_mechanic 05-09 Equinox Maintenance 0 03-15-2016 08:34 PM
Blower problems Jaws 05-09 Equinox Maintenance 9 12-12-2015 04:09 PM