Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

2014 Equinox


This is a discussion on 2014 Equinox within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
Hi, I am new here, i searched through all of the threads to try and find my question but didn't ...





Reply
 
LinkBack Thread Tools Display Modes
Old 03-18-2015, 10:24 AM   #1 (permalink)
Junior Member
 
Join Date: Mar 2015
Location: Ohio
Age: 50
Posts: 3
Rep Power: 0
Lisau is on a distinguished road
Default 2014 Equinox

Hi,
I am new here, i searched through all of the threads to try and find my question but didn't see anything related to it so i thought i would start a new one. My Equinox has just turned over 15,000 miles. The past few weeks I have been noticing when i am sitting in drive at a light or stopped, vibration inside the car. I can feel it in my hands and my legs and my water bottle in my console also vibrates. I do not notice it when i am driving. My oil has been changed every 3000 miles or so. My brother works at the dealership i bought it at, he does all my maintanence, and when i asked him he said not to worry about it. i dont think it should do this, i have a 2000 cavalier with 230,000 miles on it and i cant even tell its running at a stop light in drive. I wouldnt think an almost brand new car would run that way normally. Like i said i never noticed it before until just recent. Anyone else have this issue? its getting kind of annoying.. Thanks.Lisa
Lisau is offline   Reply With Quote
Old 03-18-2015, 11:05 PM   #2 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Does this happen when Eco mode is engaged or disengaged?

This may just be something that the dealer can do with a simple software update that your car may be lacking. If it doesn't have anything to do with ECO mode then I would have the Chevy Dealer check it out!
dietz4ibanez is offline   Reply With Quote
Old 03-19-2015, 09:31 AM   #3 (permalink)
Junior Member
 
Join Date: Mar 2015
Location: Ohio
Age: 50
Posts: 3
Rep Power: 0
Lisau is on a distinguished road
Default

Originally Posted by dietz4ibanez View Post
Does this happen when Eco mode is engaged or disengaged?

This may just be something that the dealer can do with a simple software update that your car may be lacking. If it doesn't have anything to do with ECO mode then I would have the Chevy Dealer check it out!
Hi,
Funny you say that, i read somewhere on the internet when i was trying to search this about the ECO mode, since i kind of just recently turned it on, when i started noticing the vibration. So i turned it off yesterday and i think it kind of feels better but i believe it is still there. I didnt know what the ECO really did, if it had to do with the motor running, or if it was the tranny.
Lisau is offline   Reply With Quote
Old 03-19-2015, 12:45 PM   #4 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Originally Posted by Lisau View Post
Hi,
Funny you say that, i read somewhere on the internet when i was trying to search this about the ECO mode, since i kind of just recently turned it on, when i started noticing the vibration. So i turned it off yesterday and i think it kind of feels better but i believe it is still there. I didnt know what the ECO really did, if it had to do with the motor running, or if it was the tranny.
From what I understand the ECO mode is to save economy during city driving. I always thought it was the other way around but I'm pretty sure if I had a 4cyl. I probably would pay no mind to the Eco mode as I would always forget to transition it ON/OFF when needed to.

Drive it with it off and report back if it improves. If not, I'd take it in, it should be something simple.

BTW, even though the Cavalier wasn't the best of quality, overall it was a really good car! We had one with 140k on the original clutch before we sold it. My only cost in maintenance for that car was brakes and 2 bushings in the front suspension that cost $40. I wouldn't have needed to replace them if I hadn't installed a lowering kit that I later uninstalled to improve car handling... Ha ha
dietz4ibanez is offline   Reply With Quote
Old 03-19-2015, 01:52 PM   #5 (permalink)
Junior Member
 
Join Date: Mar 2015
Location: Ohio
Age: 50
Posts: 3
Rep Power: 0
Lisau is on a distinguished road
Default

Originally Posted by dietz4ibanez View Post
From what I understand the ECO mode is to save economy during city driving. I always thought it was the other way around but I'm pretty sure if I had a 4cyl. I probably would pay no mind to the Eco mode as I would always forget to transition it ON/OFF when needed to.

Drive it with it off and report back if it improves. If not, I'd take it in, it should be something simple.

BTW, even though the Cavalier wasn't the best of quality, overall it was a really good car! We had one with 140k on the original clutch before we sold it. My only cost in maintenance for that car was brakes and 2 bushings in the front suspension that cost $40. I wouldn't have needed to replace them if I hadn't installed a lowering kit that I later uninstalled to improve car handling... Ha ha
I bought the cavalier from California and it had 140,000 miles on it. i have had it for almost 6 years now and put almost 100,000 miles on it. never had to do much to it except oil changes and a water pump once and recent fuel pump. I have knocking in the front end when i turn the wheel in slow speed for some time now, but nothing has broke yet, i am curious what is doing it though, i have been told nothing wrong with it. Thanks for the info about the Equinox. Like i said my brother works at the dealer we got it at and he tells me dont worry about it. I think he just doesnt want to work on it. lol. I leave the eco off now.
Lisau is offline   Reply With Quote
Old 03-19-2015, 06:12 PM   #6 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

I would bet that knocking or loud clicking might be the cv axle.
dietz4ibanez is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bluetooth issues with 2014 Equinox bigbillsd Audio & Electronics 8 08-20-2015 05:27 PM
2014 Equinox Transmission issue WAHLQUIST1981 2010+ Equinox Maintenance 1 03-17-2015 10:21 PM
Test Drove a 2014 4-cylinder AWD Equinox Max_Powers 2010+ Equinox General Forum 4 11-04-2014 03:22 PM
2014 Equinox locks Equa 2010+ Equinox Maintenance 6 03-03-2014 03:53 PM
2014 Equinox LS - want remote start! rkhendrickson Audio & Electronics 3 12-14-2013 05:28 PM