Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

2013 LT loss of engine power


This is a discussion on 2013 LT loss of engine power within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
I was accelerating up a ramp onto I-4 and when I got near the top the engine lost power. I ...





Reply
 
LinkBack Thread Tools Display Modes
Old 10-07-2016, 05:19 PM   #1 (permalink)
Junior Member
 
Join Date: Mar 2015
Age: 53
Posts: 1
Rep Power: 0
jdsausville is on a distinguished road
Default 2013 LT loss of engine power

I was accelerating up a ramp onto I-4 and when I got near the top the engine lost power. I could floor the accelerator and it would wind out and keep moving very slow. I limped it home, and I'm trying to figure out what's wrong. A day ago the check engine light came on, and I had it read @ O'reilley's. Got back P0420 code. I have over 201200 miles on this vehicle, and beat it very severely with my job. I change the oil very often, as these engines are insane on using oil. It seems to shift fine, but has hardly any power. When I put it in park or neutral, and floor the accelerator...it revs right up. Is this possibly a clogged Cat converter or O2 sensor. I hate to take it to the dealer if it's something I can fix myself. I'm trying to baby it until after the 1st of the year and then buy a new one. Any and all help will be greatly appreciated!!!!! Thank you!!!
jdsausville is offline   Reply With Quote
Old 10-16-2016, 02:07 PM   #2 (permalink)
LMP
Junior Member
 
Join Date: Oct 2016
Location: Chicoutimi QC Canada
Posts: 2
Rep Power: 0
LMP is on a distinguished road
Default

Referring to numerous forum readings about this engine , the mileage you show and the condition in which it occured, I would suspect the timing chain has slipped one or more cogs. What you described has also happened to me and several others with the Ford V8 302 or long gone years and the symptoms you describe are exactly that. With the EquinoxL4 it seems the tensioner might be the culprit, at least in part. A compression test would reveal a loss of compression.
LMP is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
power steering message bawbeebee 2010+ Equinox General Forum 4 10-19-2017 09:34 PM
Power locks JimSTL The Official "How To:" Section 3 12-10-2015 09:46 PM
power steering electrical dcpophb 05-09 Equinox Maintenance 0 09-30-2015 12:37 AM
2010 Chevy Equinox v6 3.0 Reduced Engine Power/Replace Stabiltrack dietz4ibanez Engine & Performance Modifications 6 07-08-2014 06:01 PM
12 volt Power outlets wlachney 2010+ Equinox General Forum 1 04-25-2012 10:00 AM