Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

2012 Equinox radio buttons, a/c dial..etc not working


This is a discussion on 2012 Equinox radio buttons, a/c dial..etc not working within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
All of a sudden I can no longer use any radio controls on the dash unit (steering buttons work) Also ...





Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 10-17-2015, 10:10 PM   #1 (permalink)
Junior Member
 
Join Date: Oct 2015
Posts: 3
Rep Power: 0
ryan1522 is on a distinguished road
Default 2012 Equinox radio buttons, a/c dial..etc not working

All of a sudden I can no longer use any radio controls on the dash unit (steering buttons work) Also the buttons for defrost, a/c..etc don't work. The hazard button works and lock/unlock. The radio works and lights up but the buttons that don't work don't light up. Checked all fuses and they seem ok. Is there some relay I should check????
ryan1522 is offline   Reply With Quote
Old 11-19-2015, 06:30 PM   #2 (permalink)
Junior Member
 
Join Date: Nov 2015
Age: 40
Posts: 1
Rep Power: 0
Sportsfan is on a distinguished road
Default

I just experienced the same problem. Took the vehicle to my mechanic and he has not idea what is wrong with it. Where you able to fix yours?
Sportsfan is offline   Reply With Quote
Old 11-24-2015, 10:18 PM   #3 (permalink)
Junior Member
 
Join Date: Oct 2015
Posts: 3
Rep Power: 0
ryan1522 is on a distinguished road
Default

Originally Posted by Sportsfan View Post
I just experienced the same problem. Took the vehicle to my mechanic and he has not idea what is wrong with it. Where you able to fix yours?
I called GM and they had me bring it into the dealer. The dealer took it (head counsel) cleaned it and reinstalled. At this time it is working fine. They are not sure what happened. A few weeks after one time when I started the car up the volume shot up quickly and I turned it down. Since then nothing has happened. It is possible this is a known glitch with GM.
ryan1522 is offline   Reply With Quote
Old 11-25-2015, 05:21 AM   #4 (permalink)
Member
 
Join Date: Oct 2015
Age: 43
Posts: 34
Rep Power: 0
Svard75 is on a distinguished road
Default

The connector can often become corroded if there are higher levels of humidity. I usually address any strange intermittent problems by removing the component connectors, viewing the pins and cleaning with a tooth brush then apply dielectric grease to the surrounding rubber seal and plug back in. Don't get too much grease on the connectors.


Sent from my iPhone using Tapatalk
Svard75 is offline   Reply With Quote
Old 01-17-2016, 01:37 AM   #5 (permalink)
Junior Member
 
Join Date: Jan 2016
Age: 30
Posts: 2
Rep Power: 0
Tiffer2u is on a distinguished road
Default

I have the same EXACT problem and I have taken to two places and they are at a loss like myself... I have an appointment with a dealership on Monday... Was it an expensive fix? I pray not since it's just right after Christmas... So happy I found this thread!
Tiffer2u is offline   Reply With Quote
Old 01-19-2016, 09:28 AM   #6 (permalink)
Junior Member
 
Join Date: Sep 2015
Posts: 7
Rep Power: 0
Masterkevj is on a distinguished road
Default

Did any of you notice if this happened after using the remote start? I'm thinking maybe it doesn't "wake" the system up when you put the key in as all those controls are disabled while the remote start is activated. It did, however, connect my Bluetooth even though all the radio and hvac controls were inoperable. But when I went to use my phone the Bluetooth activated and suddenly it "woke up" and everything started working fine. Just my 2 cents, any thoughts?
Masterkevj is offline   Reply With Quote
Old 03-05-2017, 04:43 PM   #7 (permalink)
Junior Member
 
Join Date: Mar 2017
Posts: 1
Rep Power: 0
Cash954 is on a distinguished road
Default

Did the dealer charge you to fix the problem? I have a 2015 equinox
Cash954 is offline   Reply With Quote
Old 03-07-2017, 02:17 PM   #8 (permalink)
Junior Member
 
Join Date: Mar 2017
Posts: 2
Rep Power: 0
Kcdreamz is on a distinguished road
Default

Originally Posted by Cash954 View Post
Did the dealer charge you to fix the problem? I have a 2015 equinox
Are you having the same problem with your 2015
Kcdreamz is offline   Reply With Quote
Old 03-07-2017, 02:20 PM   #9 (permalink)
Junior Member
 
Join Date: Mar 2017
Posts: 2
Rep Power: 0
Kcdreamz is on a distinguished road
Default

Originally Posted by ryan1522 View Post
All of a sudden I can no longer use any radio controls on the dash unit (steering buttons work) Also the buttons for defrost, a/c..etc don't work. The hazard button works and lock/unlock. The radio works and lights up but the buttons that don't work don't light up. Checked all fuses and they seem ok. Is there some relay I should check????
Do you get this problem firgured out?? I have a 2015 with the same problems..
Kcdreamz is offline   Reply With Quote
Old 04-28-2017, 08:33 PM   #10 (permalink)
Junior Member
 
Join Date: Apr 2017
Posts: 1
Rep Power: 0
01teaser is on a distinguished road
Default

I have a 2013 Equinox and I haven't had any problems with it until now.
My Infotainment system suddenly quit working. No radio, no control of any of the buttons on the console. My AC/heater fan is not working and I am unable to change any settings. NOTHING!!
I am not a auto mechanic but I figured I would start at the easiest fix, fuses. So far, I got my radio playing the station it was on went everything stopped but I can not turn the volume up or down, I can not change the station, I can't even turn the radio off!!!
I've noticed others having the same problems. Has anyone found the problem or solution? Any directions to fix this would greatly be appreciated.
01teaser is offline   Reply With Quote
Old 05-03-2017, 11:10 PM   #11 (permalink)
Junior Member
 
Join Date: May 2017
Age: 3
Posts: 1
Rep Power: 0
3311 is on a distinguished road
Default

Originally Posted by 01teaser View Post
I have a 2013 Equinox and I haven't had any problems with it until now.
My Infotainment system suddenly quit working. No radio, no control of any of the buttons on the console. My AC/heater fan is not working and I am unable to change any settings. NOTHING!!
I am not a auto mechanic but I figured I would start at the easiest fix, fuses. So far, I got my radio playing the station it was on went everything stopped but I can not turn the volume up or down, I can not change the station, I can't even turn the radio off!!!
I've noticed others having the same problems. Has anyone found the problem or solution? Any directions to fix this would greatly be appreciated.
I too, have a 2013 Equionx LT. I hadn't been having any problems with the screen, up until this week. Sunday evening, I noticed my dash lights & the Mylink screen were dimmer than normal driving home. I left for work Monday & while backing out of the driveway, the camera was dim and at the bottom it said something like "check your surrounds." Today, halfway to work, it brightened up. On the way home, it dimmed down. My heat is still working. I haven't used my a/c much, but someone did make a comment that the fan motor of the a/c sounded loud. I don't know where to begin. It's out of warranty.
What I'm not understanding, is that if there are so many issues/problems going on like this, why doesn't GM put a recall out? Because they don't know how to fix it? And it just doesn't seem to be one specific year. Maybe we need to start complaining to GM.
3311 is offline   Reply With Quote
Old 05-20-2017, 09:57 PM   #12 (permalink)
Junior Member
 
Join Date: May 2017
Age: 45
Posts: 1
Rep Power: 0
IM2PCHEE4U is on a distinguished road
Default

My 2012 just did the same thing. My fiancÚ got the screen to unfreeze and got the buttons to work again BY starting the car WITH the remote. Then everything went back to normal. Don't know why it "froze" in the first place though.
IM2PCHEE4U is offline   Reply With Quote
Old 07-11-2017, 12:06 AM   #13 (permalink)
Junior Member
 
Join Date: Jul 2017
Age: 34
Posts: 1
Rep Power: 0
TiffTuck is on a distinguished road
Default

Did anyone find a solution? My 2012 equinox radio/screen has no sound. You can't hear the blinker or seat belt indicator. My air condition controls works fine. I've checked fuses under the hood and in the vehicle, disconnected the battery and reconnected, unhooked the radio and plugged it back in. Heeeeeelp
TiffTuck is offline   Reply With Quote
Old 10-18-2017, 07:46 PM   #14 (permalink)
Junior Member
 
Join Date: Oct 2017
Age: 62
Posts: 1
Rep Power: 0
Karenea is on a distinguished road
Default

Originally Posted by Kcdreamz View Post
Do you get this problem firgured out?? I have a 2015 with the same problems..
FYI....We have a 2014 equinox that suddenly the radio controls and the heater/AC controls stopped working it was still under warranty so we took it into the dealer thinking it was electrical. They ran codes and didn't find anything, uninstalled the battery and reconnected it and everything was working properly.
Karenea is offline   Reply With Quote
Old 12-06-2017, 08:21 AM   #15 (permalink)
Junior Member
 
Join Date: Dec 2017
Age: 42
Posts: 1
Rep Power: 0
Madmike is on a distinguished road
Default 2013 equanox heat/AC radio cluster not working

I had this problem this morning with my equinox. Checked the fuses and connectors. All were good. disengaged bluetooth disconnected posative battery terminal for a couple of minuites and reconnected it. That reset the computer and fixed it immediatly.
Madmike is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
15 Equinox Nav not working R Dub 2010+ Equinox General Forum 6 07-29-2016 11:06 AM
2010 Equinox Bluetooth just stopped working one day ryano1124 2010+ Equinox General Forum 1 09-23-2014 09:18 AM
2010 Equinox - Screen Not working katie Audio & Electronics 1 12-05-2013 02:34 PM
Radio display and mileage display not working Pbrenz 05-09 Equinox General Forum 0 06-02-2013 09:40 PM
2012 Chevy Volt And Equinox To Gain Pandora Radio Streaming dietz4ibanez Audio & Electronics 1 03-27-2012 02:11 PM