Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

2011 1LT V6 3.9k: Seems like A/C is always ON


This is a discussion on 2011 1LT V6 3.9k: Seems like A/C is always ON within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
2011 1LT V6 3.9k: Seems like A/C is always ON Took the vehicle on a 160-mile roundtrip drive last night. ...





Reply
 
LinkBack Thread Tools Display Modes
Old 05-26-2011, 01:28 PM   #1 (permalink)
Member
 
Join Date: Feb 2011
Posts: 46
Rep Power: 0
Colt Hero is on a distinguished road
Default 2011 1LT V6 3.9k: Seems like A/C is always ON

2011 1LT V6 3.9k: Seems like A/C is always ON

Took the vehicle on a 160-mile roundtrip drive last night. I did NOT turn on the A/C (the "snowflake" light was OFF), but I DID select RECIRCULATE and turn on the fan. I also did NOT have the defroster on (both buttons' lights were OFF).

I definitely was getting A/C-coolish air from the ducts the entire trip. Had to turn the fan down to level 1 because it actually got too cold.

I then tried pressing the "snowflake" button to make sure it wasn't on, and when I did I saw "A/C ON" displayed on the LCD and the amber light on the button illuminated. Pressing it again displayed "A/C OFF" (and the amber light went out). So the A/C was definitely (selected to be) OFF, but I was still getting A/C-like air from the ducts.

Is this right? Is the A/C activated anyway if you turn on the fan with Recirculate selected and the A/C and defrosters both OFF???
Colt Hero is offline   Reply With Quote
Old 05-26-2011, 02:32 PM   #2 (permalink)
Senior Member
 
2010BlkGraniteNox's Avatar
 
Join Date: Jul 2010
Location: Viera, FL
Posts: 398
Rep Power: 10
2010BlkGraniteNox is on a distinguished road
Default

Originally Posted by Colt Hero View Post
2011 1LT V6 3.9k: Seems like A/C is always ON

Took the vehicle on a 160-mile roundtrip drive last night. I did NOT turn on the A/C (the "snowflake" light was OFF), but I DID select RECIRCULATE and turn on the fan. I also did NOT have the defroster on (both buttons' lights were OFF).

I definitely was getting A/C-coolish air from the ducts the entire trip. Had to turn the fan down to level 1 because it actually got too cold.

I then tried pressing the "snowflake" button to make sure it wasn't on, and when I did I saw "A/C ON" displayed on the LCD and the amber light on the button illuminated. Pressing it again displayed "A/C OFF" (and the amber light went out). So the A/C was definitely (selected to be) OFF, but I was still getting A/C-like air from the ducts.

Is this right? Is the A/C activated anyway if you turn on the fan with Recirculate selected and the A/C and defrosters both OFF???

If you have recirculate selected, the AC is on (works that w/ the 1LT and 2LT (auto air)...if you choice outside air, ac off, then its just fan blowing
__________________
2010 Black Granite Equnox 2LT
HFV6/Jet Leather/Tow/Cargo/PwrLift *retired..great setup!*
2010 Silvermist Equinox 1LT *retired 27mpg avg*

2012 Silver Imapala LT 3.6 VVT SIDI 304HP (work car)
2012 Audi A3 Sportback Premium Plus TDI (current)
2010BlkGraniteNox is offline   Reply With Quote
Old 05-27-2011, 02:47 AM   #3 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 37
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

I have always thought that recirculating blows the coldest air.
dietz4ibanez is offline   Reply With Quote
Old 05-27-2011, 01:52 PM   #4 (permalink)
Member
 
Join Date: Feb 2011
Posts: 46
Rep Power: 0
Colt Hero is on a distinguished road
Default

This is a new phenomena to me, but OK.
Colt Hero is offline   Reply With Quote
Old 06-02-2011, 07:47 PM   #5 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 37
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Every car is different is what I always say.
dietz4ibanez is offline   Reply With Quote
Old 06-06-2011, 04:55 PM   #6 (permalink)
Senior Member
 
Lenn's Avatar
 
Join Date: Apr 2011
Location: Beaumont, TX
Age: 36
Posts: 192
Rep Power: 9
Lenn is on a distinguished road
Default

This could be a software glitch. If you have electronic climate controls, take it in to the dealer and let them know about the issue... if there in fact is one. They'll let you know how the proper operation is supposed to work and if there's an actual issue, it sounds to me like a software reprogram of the ECC module should take care of things.
__________________
Lenn is offline   Reply With Quote
Old 06-06-2011, 05:00 PM   #7 (permalink)
Senior Member
 
Lenn's Avatar
 
Join Date: Apr 2011
Location: Beaumont, TX
Age: 36
Posts: 192
Rep Power: 9
Lenn is on a distinguished road
Default

Originally Posted by dietz4ibanez View Post
I have always thought that recirculating blows the coldest air.
Recirc blows the coldest air if ambient temp is high. Reason being is that if you have the A/C on, the air temp inside the car is considerably lower than ambient. Recirc just keeps the air inside the car moving and recirculating thru the HVAC system without actually pulling in more air from the outside (warmer air), thereby maintaining a cooler temp. Basically, its cooling already cool air.

With the A/C off, thermal dynamics will eventually heat up the air inside the car thru the glass and slowly raise the temp inside the car... but still considerably slower than turning off recirc and leaving off the A/C.

The drawback to using recirc only is that its been proven by the NHTSA/IIHS to contribute to premature driver fatigue on long trips. A little fresh air by turning off the recirc can help keep you more alert for longer. Plus, the air inside the car starts to smell stale after a while.
__________________
Lenn is offline   Reply With Quote
Old 06-07-2011, 08:41 AM   #8 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 37
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Trust me Lenn. After a couple of hours riding in the car I have to stop for fresh air...




Sent from my DROIDX using Tapatalk
dietz4ibanez is offline   Reply With Quote
Old 06-07-2011, 09:52 PM   #9 (permalink)
Super Mod
 
Z_Ghost's Avatar
 
Join Date: Nov 2010
Location: Texas
Age: 62
Posts: 1,586
Rep Power: 11
Z_Ghost is on a distinguished road
Default

I supply my own fresh air, well it's not that fresh and I would have to say it's not really what you want to be breathing in.
So I do roll the windows down every now and then.
Please do not light a match in my terrain...

Have to use Recirc almost all the time not the temps are pushing 100* Takes a long time to cool it down after sitting in the sun for a few hours.
__________________
2011 Terrain SLT2 Carbon Black I4 FWD
92 B4C Camaro - X Texas HWY Patrol car
ZZ4, SuperRam, Holley 52 mm TB, T-56.
92 Z/28
60\'1.937-1/4 13.851-98.16 mph


Last edited by Z_Ghost; 07-05-2011 at 06:03 AM.
Z_Ghost is offline   Reply With Quote
Old 06-23-2011, 08:57 AM   #10 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 37
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Sometimes its hard to park in that shady spot.

Sent from my DROIDX using Tapatalk
dietz4ibanez is offline   Reply With Quote
Old 07-14-2011, 01:13 PM   #11 (permalink)
Junior Member
 
NoobNox's Avatar
 
Join Date: Jul 2011
Posts: 9
Rep Power: 0
NoobNox is on a distinguished road
Default

Originally Posted by Lenn View Post
This could be a software glitch. If you have electronic climate controls, take it in to the dealer and let them know about the issue... if there in fact is one. They'll let you know how the proper operation is supposed to work and if there's an actual issue, it sounds to me like a software reprogram of the ECC module should take care of things.
It's not a glitch, the a/c compressor kicks in when you have it set to "recirc" regardless of the a/c being turned on or not. A lot of GM car/trucks do this..
__________________
2010 Equinox 2LT Silver Ice Metallic, titanium leather, 2.4 I4
NoobNox is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On