Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

2010 transmission issues


This is a discussion on 2010 transmission issues within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
Had to take my 2010 NOX in today (70K). Tranny has been acting up but today was brutal. Parked the ...





Reply
 
LinkBack Thread Tools Display Modes
Old 11-20-2013, 05:42 PM   #1 (permalink)
Junior Member
 
Join Date: Nov 2013
Posts: 1
Rep Power: 0
GolferG is on a distinguished road
Default 2010 transmission issues

Had to take my 2010 NOX in today (70K). Tranny has been acting up but today was brutal. Parked the car on a slight incline, pressed the gas to leave the spot and car wouldn't move. It threw a CEL and off I went to the dealer. Restarted the car and it backed out of the spot ok. CEL still on.

Prior to this the car would jerk a lot in reverse and also would also suddenly rev high like it disengaged from its current gear, mid drive.

Any clue what the problem is? I'll wait to hear back from the dealer. When dealer calls, what should I be asking for...

Had lots of cars in my life but this is my 1st tranny issue...
GolferG is offline   Reply With Quote
Old 11-20-2013, 09:55 PM   #2 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 38
Posts: 4,672
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

I don't know a ton about tranny's Did you check your transmission fluid on level ground while the engine was running?

Could be a actuator or sensor. I don't think it's a actual problem with the transmission but I could be wrong.
dietz4ibanez is offline   Reply With Quote
Old 09-05-2020, 11:28 PM   #3 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 15
Rep Power: 0
burnbomber is on a distinguished road
Default

I am resurrecting this thead, as my 2010 has some weird things happening to it. On the road, of course, and towing.

Ist symptom was a harsh shift, from 5th into top 6th. This was early on, in a 600 mile day. The next symptom , after lots of miles, was a bucking drive action--it seems like no power to power to no power. Also a weird shift pattern, it would hang up in the shift, holding the lower gear far to long. Final symptom was loss of drive. No power through to the wheels. I shifted into reverse, neutal, several times. Let it rest, etc. as I scratched my head. Shifting between reverse and drive caused a loud clunk, then I had drive restored and we made it all the way home to the off ramp, where it died again. No power to the wheels, 1/4 mile home. I kept working it, booting it up, turning it off, shifting drive to reverse, and it restored itself to get it home and unloaded.

Where I promptly parked it at my storage hangar and jumped into my Miata. So, what the heck is going on??

I do have the service manual, also retreived the warranty book. Fortunately, it happened on the last load it's got to carry; I can park it and diagnose. Just turning 100k, and it's 1st problem. And, it did not throw any codes at me.
__________________
2017 Honda Pilot Elite AWD, new, top of the line loaded, splendid...the Pilot
2010 Chevy Equinox, 2.4 FWD, white with Brownstone leather...the Nox
1997 Mazda Miata, base NA with 15" OEM wheels and Oris windstop...the little red scooter

Last edited by burnbomber; 09-06-2020 at 09:58 AM.
burnbomber is offline   Reply With Quote
Old 09-09-2020, 12:16 PM   #4 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 15
Rep Power: 0
burnbomber is on a distinguished road
Default

What--no ideas from anybody?
__________________
2017 Honda Pilot Elite AWD, new, top of the line loaded, splendid...the Pilot
2010 Chevy Equinox, 2.4 FWD, white with Brownstone leather...the Nox
1997 Mazda Miata, base NA with 15" OEM wheels and Oris windstop...the little red scooter
burnbomber is offline   Reply With Quote
Old 09-10-2020, 10:38 AM   #5 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 15
Rep Power: 0
burnbomber is on a distinguished road
Default

Took it to the dealer in N KCMO. Wll advise on what they find. I'm into them for 150 diagnosis fee, and letting them keep it until they fix it. I think they'll help pay for it. My book says transmission warranty is 8 years, 100 k miles. I'm at 10 years and 99.5k miles. I know they extended it to 10 years and 120 k miles on something engine related.

Hated to do that, but I don't have time to do it--still moving into my 2 story duplex in KCMO. Gonna hire it out, hope it doesn't cost me both arms.
__________________
2017 Honda Pilot Elite AWD, new, top of the line loaded, splendid...the Pilot
2010 Chevy Equinox, 2.4 FWD, white with Brownstone leather...the Nox
1997 Mazda Miata, base NA with 15" OEM wheels and Oris windstop...the little red scooter
burnbomber is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
transmission change jherman 2010+ Equinox Maintenance 11 11-01-2013 08:23 PM
Hatch issues cmiller7786 05-09 Equinox General Forum 2 07-09-2013 11:49 AM
'13 transmission filter SportNox 2010+ Equinox Maintenance 5 01-15-2013 08:21 AM
Transmission Issue jsfb6pts 2010+ Equinox General Forum 3 08-19-2012 10:24 PM
Transmission/Startup problems amtraker 2010+ Equinox General Forum 2 12-08-2011 06:18 AM