Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

2010 nox rough idle


This is a discussion on 2010 nox rough idle within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
I have a 2010 nox and love it, but it seems that it idles a little rough when it is ...





Like Tree1Likes
  • 1 Post By rbiggers

Reply
 
LinkBack Thread Tools Display Modes
Old 09-12-2011, 06:44 PM   #1 (permalink)
Junior Member
 
Join Date: Sep 2011
Age: 46
Posts: 11
Rep Power: 0
jherman is on a distinguished road
Default 2010 nox rough idle

I have a 2010 nox and love it, but it seems that it idles a little rough when it is stopped. Doesn't matter if it is in gear or neutral or if the engine is warm or not. Just wondering if they all idle a little rough, or if I should take it in to have a tech look at it?
jherman is offline   Reply With Quote
Old 09-12-2011, 10:21 PM   #2 (permalink)
Senior Member
 
rbiggers's Avatar
 
Join Date: Nov 2010
Location: Midland, Texas
Posts: 518
Rep Power: 9
rbiggers is on a distinguished road
Default

No rough idle here. Might want to take it in for a check up just in case.
K9Tex likes this.
__________________
2012 Chevy Traverse

2011 Chevy Silverado LT 4X4 CC 6.2L - Sheer Silver Metallic
rbiggers is offline   Reply With Quote
Old 09-12-2011, 10:39 PM   #3 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Yeah it sounds like it may need a reflash on the ECM.
dietz4ibanez is offline   Reply With Quote
Old 04-13-2012, 07:33 PM   #4 (permalink)
rob
Junior Member
 
Join Date: Apr 2012
Posts: 5
Rep Power: 0
rob is on a distinguished road
Default

I had a very similar problem with my 2010 last fall. At first it was a nuisance and the dealer claimed it was a sensor which they replaced twice. It finally got so bad that when sitting and idling the car would barely stay running. This time they said it was the fuel pump and replaced it. I've begun to notice that it is starting to come back so suspect that the problem is slowly returning.

Interestingly my brother and his wife also had a 2010 Nox and they went through three fuel pumps in less then a year. The dealership finally bought the car back from them and they got a 2011. The problem has not returned for them.
rob is offline   Reply With Quote
Old 04-13-2012, 11:40 PM   #5 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

That's so weird.
dietz4ibanez is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 V6 1LT 700 miles: Odd, subtle, continuous noise at idle Colt Hero 2010+ Equinox General Forum 4 02-11-2011 11:59 PM