Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

2.4 issues


This is a discussion on 2.4 issues within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
...





Reply
 
LinkBack Thread Tools Display Modes
Old 07-25-2020, 09:34 PM   #1 (permalink)
Junior Member
 
Join Date: Jul 2020
Location: Lincoln Kansas
Age: 48
Posts: 3
Rep Power: 0
Butch12772 is on a distinguished road
Default 2.4 issues

I have a 2010 Equinox with 160,000 miles. For a long time it has been stalling shortly after starting when the engine is cold. I have replaced the plugs and boots. Replaced the intake and exhaust am sensors. O2 sensors. all with no change. Today I went after the intake manifold gasket. While there I removed the fuel injectors to clean them. Put it all together now it barely runs at all. Codes P228C, C0765, P0300, U0100. Missing like crazy and black smoke from exhaust. Supply fuel pressure is 57 psi. Rail pressure is 443 psi. Took it all apart a second time but canít find anything.
Butch12772 is offline   Reply With Quote
Old 08-01-2020, 10:52 AM   #2 (permalink)
Junior Member
 
Join Date: Jul 2020
Location: Lincoln Kansas
Age: 48
Posts: 3
Rep Power: 0
Butch12772 is on a distinguished road
Default

I replaced the injectors, fuel rail, and harness with a salvage set and it’s running again. Same as before.
Butch12772 is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
08 fuel issues Lsisson92 05-09 Equinox General Forum 1 09-30-2018 10:04 AM
05 Equinox Issues taz1458 05-09 Equinox Maintenance 2 01-19-2018 04:08 PM
Starting Issues? Sheathom 2010+ Equinox Maintenance 0 06-13-2017 08:52 PM
A/c issues Cutlass4x4 2010+ Equinox Maintenance 1 03-27-2017 12:30 PM
Hatch issues cmiller7786 05-09 Equinox General Forum 2 07-09-2013 11:49 AM