Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 2010+ Equinox General Forum

2010+ Equinox General Forum

15 Equinox Nav not working


This is a discussion on 15 Equinox Nav not working within the 2010+ Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
Hello all, Would first like to say sorry if this is posted in the wrong place. My wife and I ...





Reply
 
LinkBack Thread Tools Display Modes
Old 08-18-2015, 03:46 PM   #1 (permalink)
Junior Member
 
Join Date: Aug 2015
Location: Burbs of Chicago
Posts: 2
Rep Power: 0
R Dub is on a distinguished road
Default 15 Equinox Nav not working

Hello all,

Would first like to say sorry if this is posted in the wrong place. My wife and I bought a brand new 2015 LT2 Equinox back in March of this year. Since this it has spent the majority of it's life at the shop attempting to get repaired. The issue is the arrow on the navigation system will randomly show you off of the road (Has me in a pond in the video).When this happens, it starts to go crazy and tells you to turn right/left/uturn very rapidly as you can see in the video in the link. It will not correct itself until the car is fully shut off. The dealer said they have replaced every single part that deals with the nav system and it is still doing it. Has any other member experenced this with there 15 Equinox?



http://vid582.photobucket.com/albums...ideo%208-7.mp4
R Dub is offline   Reply With Quote
Old 08-31-2015, 11:42 AM   #2 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Sounds like it needs reprogrammed, something that can be done at the dealership.
dietz4ibanez is offline   Reply With Quote
Old 09-30-2015, 09:21 PM   #3 (permalink)
Junior Member
 
Join Date: Aug 2015
Location: Burbs of Chicago
Posts: 2
Rep Power: 0
R Dub is on a distinguished road
Default

Just wanted to provide an update. Chevy said that this is a known issue on all 2015 and 2016 models and there is no known fix. Therefore the bought the vehicle back from me. My advise is do not buy a 2015 or 2016 Chevy Equinox with Nav. Wait until they are redone in 2017.
R Dub is offline   Reply With Quote
Old 09-30-2015, 10:58 PM   #4 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Originally Posted by R Dub View Post
Just wanted to provide an update. Chevy said that this is a known issue on all 2015 and 2016 models and there is no known fix. Therefore the bought the vehicle back from me. My advise is do not buy a 2015 or 2016 Chevy Equinox with Nav. Wait until they are redone in 2017.
What did you get to replace it?
dietz4ibanez is offline   Reply With Quote
Old 10-04-2015, 07:26 PM   #5 (permalink)
Junior Member
 
Join Date: Oct 2011
Posts: 17
Rep Power: 0
johns4949 is on a distinguished road
Default

How about these problems on a 2015 Equinox

3) Display does not switch from night to daylight all the time. Sometimes it take up to an hour for the display to switch to daytime after it is daylight out.
4) Display will switch into night mode during the day occasionally.
5) Sometimes the display will go to the home mode all by itself.
6) XM radio will go to XM preview and not stay on station when car is started up occasionally.
7) Put in reverse then to drive, screen goes to HOME page and not where it was sometimes.
8) When asking to continue navigation. Hit YES and navigation screen does not come on, it goes to a radio station.
9) Navigation will not ask to continue navigation sometimes. When I hit Navigation button it goes to home page.
10) USB/IPOD – When car is shut off and then restarted the system goes to the AM source mode and not back to USB/IPOD. I have to disconnect the IPOD and reconnect it again.
11) USB/IPOD – Shows song and album artwork like it should. The system drops the IPOD screen and goes to the homepage by itself. I have to manually go back to USB/IPOD source and reconnect the IPOD.
12) USB/IPOD – When restarting car, often the IPOD will lock up and not work properly. The IPOD works off and on and not like it is supposed to. I have to force shut down the IPOD and re-connect again.
On a recent 1400 mile trip the following problems occurred:
1) Listening to XM radio the screen reverts to home page and stops playing.
2) Listening to XM radio, turn car off, start car and it goes to home page.
3) Listening to XM radio, backup camera on, put in drive it goes to home page.
4) USB/IPOD playing, stops playing and goes to AM station. Have to force shutdown IPOD and re-connect to get it to work. ( This happens a lot )
5) Hit ‘YES’ to resume navigation, screen goes to map but navigation never starts back up again.
6) Car stopped, enter previous destination on navigation. Screen goes black and says “calculating route”. The navigation screen never comes up. Have to shut car down and restart the car to get the navigation to work again. Sometimes it takes shutting the car down and waiting 15 minutes.
7) IPOD/USA Hit steering wheel control to change track. Will not advance to next song or album. When song finishes it goes to next album and no artwork.
8) Several times backup camera does not come on until I go to park and reverse again.
johns4949 is offline   Reply With Quote
Old 07-29-2016, 10:00 AM   #6 (permalink)
Junior Member
 
Join Date: Jul 2016
Posts: 2
Rep Power: 0
edwardc7 is on a distinguished road
Default Same problem on 2016

Originally Posted by R Dub View Post
Hello all,

Would first like to say sorry if this is posted in the wrong place. My wife and I bought a brand new 2015 LT2 Equinox back in March of this year. Since this it has spent the majority of it's life at the shop attempting to get repaired. The issue is the arrow on the navigation system will randomly show you off of the road (Has me in a pond in the video).When this happens, it starts to go crazy and tells you to turn right/left/uturn very rapidly as you can see in the video in the link. It will not correct itself until the car is fully shut off. The dealer said they have replaced every single part that deals with the nav system and it is still doing it. Has any other member experenced this with there 15 Equinox?



http://vid582.photobucket.com/albums...ideo%208-7.mp4
I am having the exact same problem on a new 2016 LTZ. Have had it back to the dealer twice with no success.
edwardc7 is offline   Reply With Quote
Old 07-29-2016, 10:06 AM   #7 (permalink)
Junior Member
 
Join Date: Jul 2016
Posts: 2
Rep Power: 0
edwardc7 is on a distinguished road
Default

My 2016 LTZ does exactly the same thing. I have to pull off the road and ask OnStar for my location when this happens and report back to dealer. I have given them a half dozen of the locations where this has happened and several pictures. They (GM) won't try anything. Just keep wasting my time with trips back to the dealer. I can't depend on this Nav system, so we have to carry a Garmin GPS which always works when the GM system doesn't.
edwardc7 is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
AUX stereo function not working achtung3945 Audio & Electronics 7 05-31-2019 04:59 PM
DRL Resistor not working, where can I get it? Arn2013 05-09 Equinox Maintenance 1 04-16-2016 03:32 PM
2010 Equinox Bluetooth just stopped working one day ryano1124 2010+ Equinox General Forum 1 09-23-2014 08:18 AM
2010 Equinox - Screen Not working katie Audio & Electronics 1 12-05-2013 02:34 PM
Not working drivers dore. oleg1981 The Official "How To:" Section 3 07-13-2013 12:57 AM