Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum

Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum (http://www.chevyequinoxforum.com/)
-   2010+ Equinox General Forum (http://www.chevyequinoxforum.com/f4/)
-   -   15 Equinox Nav not working (http://www.chevyequinoxforum.com/f4/15-equinox-nav-not-working-1418/)

R Dub 08-18-2015 03:46 PM

15 Equinox Nav not working
 
Hello all,

Would first like to say sorry if this is posted in the wrong place. My wife and I bought a brand new 2015 LT2 Equinox back in March of this year. Since this it has spent the majority of it's life at the shop attempting to get repaired. The issue is the arrow on the navigation system will randomly show you off of the road (Has me in a pond in the video).When this happens, it starts to go crazy and tells you to turn right/left/uturn very rapidly as you can see in the video in the link. It will not correct itself until the car is fully shut off. The dealer said they have replaced every single part that deals with the nav system and it is still doing it. Has any other member experenced this with there 15 Equinox?



http://vid582.photobucket.com/albums...ideo%208-7.mp4

dietz4ibanez 08-31-2015 11:42 AM

Sounds like it needs reprogrammed, something that can be done at the dealership.

R Dub 09-30-2015 09:21 PM

Just wanted to provide an update. Chevy said that this is a known issue on all 2015 and 2016 models and there is no known fix. Therefore the bought the vehicle back from me. My advise is do not buy a 2015 or 2016 Chevy Equinox with Nav. Wait until they are redone in 2017.

dietz4ibanez 09-30-2015 10:58 PM

Quote:

Originally Posted by R Dub (Post 13039)
Just wanted to provide an update. Chevy said that this is a known issue on all 2015 and 2016 models and there is no known fix. Therefore the bought the vehicle back from me. My advise is do not buy a 2015 or 2016 Chevy Equinox with Nav. Wait until they are redone in 2017.

What did you get to replace it?

johns4949 10-04-2015 07:26 PM

How about these problems on a 2015 Equinox ;)

3) Display does not switch from night to daylight all the time. Sometimes it take up to an hour for the display to switch to daytime after it is daylight out.
4) Display will switch into night mode during the day occasionally.
5) Sometimes the display will go to the home mode all by itself.
6) XM radio will go to XM preview and not stay on station when car is started up occasionally.
7) Put in reverse then to drive, screen goes to HOME page and not where it was sometimes.
8) When asking to continue navigation. Hit YES and navigation screen does not come on, it goes to a radio station.
9) Navigation will not ask to continue navigation sometimes. When I hit Navigation button it goes to home page.
10) USB/IPOD – When car is shut off and then restarted the system goes to the AM source mode and not back to USB/IPOD. I have to disconnect the IPOD and reconnect it again.
11) USB/IPOD – Shows song and album artwork like it should. The system drops the IPOD screen and goes to the homepage by itself. I have to manually go back to USB/IPOD source and reconnect the IPOD.
12) USB/IPOD – When restarting car, often the IPOD will lock up and not work properly. The IPOD works off and on and not like it is supposed to. I have to force shut down the IPOD and re-connect again.
On a recent 1400 mile trip the following problems occurred:
1) Listening to XM radio the screen reverts to home page and stops playing.
2) Listening to XM radio, turn car off, start car and it goes to home page.
3) Listening to XM radio, backup camera on, put in drive it goes to home page.
4) USB/IPOD playing, stops playing and goes to AM station. Have to force shutdown IPOD and re-connect to get it to work. ( This happens a lot )
5) Hit ‘YES’ to resume navigation, screen goes to map but navigation never starts back up again.
6) Car stopped, enter previous destination on navigation. Screen goes black and says “calculating route”. The navigation screen never comes up. Have to shut car down and restart the car to get the navigation to work again. Sometimes it takes shutting the car down and waiting 15 minutes.
7) IPOD/USA Hit steering wheel control to change track. Will not advance to next song or album. When song finishes it goes to next album and no artwork.
8) Several times backup camera does not come on until I go to park and reverse again.

edwardc7 07-29-2016 10:00 AM

Same problem on 2016
 
Quote:

Originally Posted by R Dub (Post 12865)
Hello all,

Would first like to say sorry if this is posted in the wrong place. My wife and I bought a brand new 2015 LT2 Equinox back in March of this year. Since this it has spent the majority of it's life at the shop attempting to get repaired. The issue is the arrow on the navigation system will randomly show you off of the road (Has me in a pond in the video).When this happens, it starts to go crazy and tells you to turn right/left/uturn very rapidly as you can see in the video in the link. It will not correct itself until the car is fully shut off. The dealer said they have replaced every single part that deals with the nav system and it is still doing it. Has any other member experenced this with there 15 Equinox?



http://vid582.photobucket.com/albums...ideo%208-7.mp4

I am having the exact same problem on a new 2016 LTZ. Have had it back to the dealer twice with no success.

edwardc7 07-29-2016 10:06 AM

My 2016 LTZ does exactly the same thing. I have to pull off the road and ask OnStar for my location when this happens and report back to dealer. I have given them a half dozen of the locations where this has happened and several pictures. They (GM) won't try anything. Just keep wasting my time with trips back to the dealer. I can't depend on this Nav system, so we have to carry a Garmin GPS which always works when the GM system doesn't.


All times are GMT -4. The time now is 07:43 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO