Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum

Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum (http://www.chevyequinoxforum.com/)
-   05-09 Equinox Maintenance (http://www.chevyequinoxforum.com/f37/)
-   -   A real head scratcher (http://www.chevyequinoxforum.com/f37/real-head-scratcher-1438/)

jdk200 09-21-2015 07:47 AM

A real head scratcher
 
Hey everyone. I seem to have a pretty serious problem with my 05 equinox. But it's a tough one. On ocassion when I go to start it up, the starter will not engage at all. You turn the key and you hear a loud thunk. On first guess you would think it's the selenoid. However If you keep at it for long enough, it will eventually start up, and then start just fine for a while after that. Now this is where it gets weird. I was stranded at work the other night because of this issue. I kept turning the key for almost an hour with no luck. Then it started up with a crazy amount of trouble codes and traction control disabled. I had to drive home in 3rd gear and it gave me a camshaft code, engine speed sensor code, crankshaft code, and a transmission control malfunction. When I get it home, clear the codes and shut it off, I try to start it again and it fires right up with no codes or issues. What the hell is going on with this thing?

dietz4ibanez 09-21-2015 02:38 PM

Did you keep record of any of those codes?

Without them we can at least guess what could be causing this behavior.

It has me thinking about the ignition module and passlok. How many miles do you have in it?

jdk200 09-21-2015 05:52 PM

Thanks for chiming in, Dietz! I sure did keep track of the codes. They are as follows- p0727,p0335,p0340,and p0700. As stated in my original post, I cleared all of them and after turning the thing off and restarting when I got it home everything was fine. Started it several times today and it has been working normally. It has 77,000 miles on it and I have an appointment with the dealer on Friday. Hopefully it doesn't act up until then. This is a horrible problem, as I basically take a risk every time I drive somewhere. When it acted up this time, it was at night and the headlights would come on normally after the first 30 attempts, then they eventually would not come on automatically. Another note, the cruise control would not work either when driving it home. I assume it was because of the codes and the fact I was stuck in 3rd gear.

dietz4ibanez 09-22-2015 11:29 AM

Being that the issue effected so many electrical components, it could even be a BCM going bad. This would also affect the ability to start the vehicle if it was going bad.

jdk200 09-22-2015 03:49 PM

I was either thinking it was the ignition switch or the PCM, not the BCM. I just wish I had proper warning before this happens. Plus I hope the dealership doesn't try to tell me it's the starter or battery. That will really piss me off.


All times are GMT -4. The time now is 12:54 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO