Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 05-09 Equinox Maintenance

05-09 Equinox Maintenance

New to the Equinox world and having trouble!


This is a discussion on New to the Equinox world and having trouble! within the 05-09 Equinox Maintenance forums, part of the Chevy Equinox General Discussion category!
My 2007 Equinox has the stabilitrak light and traction control light on, as well as the ABS light. The newest ...





Reply
 
LinkBack Thread Tools Display Modes
Old 11-08-2015, 10:02 PM   #1 (permalink)
Junior Member
 
Join Date: Nov 2015
Posts: 1
Rep Power: 0
Ngilstrap is on a distinguished road
Default New to the Equinox world and having trouble!

My 2007 Equinox has the stabilitrak light and traction control light on, as well as the ABS light. The newest addition, however, is the "Brake!" light. It started off being an intermittent problem with stabilitrak and traction control. It would only come on after a while of driving. Then the ABS light joined them. Now they are on all the time.

My research said that it could be a lot of different issues, but the one most people were suggesting was the EGR. First, I'm not sure where exactly that is located, but more importantly, I haven't noticed any performance issues. I'm not sure if the EGR valve could have an issue and not affect the performance though.

Today was the first time the "Brake!" light was on though. The check engine light has not come on at all. If anyone has any advice, I would greatly appreciate it!!! This is my wife's daily driver and I would like her vehicle to be in top condition!
Ngilstrap is offline   Reply With Quote
Old 03-01-2016, 08:17 AM   #2 (permalink)
Junior Member
 
Join Date: Mar 2016
Posts: 3
Rep Power: 0
JohnnyWinterdaal is on a distinguished road
Default

Hi Ngilstrap, I had same problem and searched all forums I could find and indeed most solution indicated the EGR valve which I did replace but it stayed the exact same. After almost two years suddenly I had ABS and a red Exclamation look alike sign and taught it was the handbrake. But no. Then realized it could be the BRAKE FLUID. And BINGO, I filled the reservoir up to the max sign and up to now (a couple of months later) all's well.
Will be hearing from you if this was a solution to you as well.
JohnnyWinterdaal is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 LS - trouble starting, etc. crj123082 05-09 Equinox General Forum 3 08-01-2015 08:43 AM
Weird trouble prheaume 05-09 Equinox Maintenance 2 08-09-2014 11:30 PM
The World's Best Airlines 2013 MaxiLina Pictures 1 08-12-2013 10:28 AM
New to the Nox world Deer_Slayer Exterior Modifications 9 08-24-2011 04:45 PM
How beer saved the world Z_Ghost The Lounge 6 02-03-2011 02:31 PM