Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 05-09 Equinox Maintenance

05-09 Equinox Maintenance

"Dry starting" sound on cold starts after oil change


This is a discussion on "Dry starting" sound on cold starts after oil change within the 05-09 Equinox Maintenance forums, part of the Chevy Equinox General Discussion category!
I have been exploring this online for a couple days but thought it would be helpful to see what actual ...





Reply
 
LinkBack Thread Tools Display Modes
Old 07-20-2017, 09:40 PM   #1 (permalink)
Junior Member
 
Join Date: Nov 2015
Posts: 7
Rep Power: 0
thuzmund is on a distinguished road
Default "Dry starting" sound on cold starts after oil change

I have been exploring this online for a couple days but thought it would be helpful to see what actual Nox owners have to say.

06 3.4L with 131K, changed oil (from valvoline high mileage to cheap walmart high mileage blend) and used a Wix filter. (nice logic, right?)

Sounds like a dry start (grinding, scratching noise for a second) on the first start of the day. After that it starts as normal.

I would swear it started after the oil change. I actually fill the filter with new oil when I change oil, but it made the sound on the first start after the change. The engine would have been fairly warm at that moment.

1) Anybody dealt with this? I think I'll probably change the oil again and see what happens, but lots of forums online have people saying don't worry about it, this little grinding is normal wear and tear.

2) More specifica question--since the 3.4L has the filter on the bottom, would a bad anti drainback valve or bypass valve on the filter cause this condition? I ask because a thread I saw said that no ADV is needed if the filter mounts "hole side up"

Thanks for sharing your thoughts!
thuzmund is offline   Reply With Quote
Reply

Bookmarks

Tags
dry start, oil filter



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 Equinox "Service Stabilitrax warning"/ zachh 2010+ Equinox Maintenance 1 01-27-2017 02:24 PM
2014 4Cyl Clicking on cold starts kenpoed 2010+ Equinox Maintenance 0 10-31-2016 11:27 AM
Happy "Belated" Birfday rwblaine82!!! dietz4ibanez The Lounge 4 06-28-2011 12:08 AM
Quite possibly the newest "Ugliest car on the planet" Lenn The Lounge 5 06-07-2011 10:27 PM
Jordan Lake-Camping Labor Day Weekend 2010 "Crapload of PICS" dietz4ibanez The Lounge 1 09-20-2010 10:11 PM