Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 05-09 Equinox Maintenance

05-09 Equinox Maintenance

2008 sport service traction control, stabilitrak


This is a discussion on 2008 sport service traction control, stabilitrak within the 05-09 Equinox Maintenance forums, part of the Chevy Equinox General Discussion category!
any ideas where to start looking? Also have a mass air flow code....





Like Tree1Likes
  • 1 Post By shafner79

Reply
 
LinkBack Thread Tools Display Modes
Old 02-27-2015, 07:50 PM   #1 (permalink)
Junior Member
 
Join Date: Feb 2015
Posts: 5
Rep Power: 0
shafner79 is on a distinguished road
Default 2008 sport service traction control, stabilitrak

any ideas where to start looking? Also have a mass air flow code.
shafner79 is offline   Reply With Quote
Old 02-28-2015, 03:53 PM   #2 (permalink)
Junior Member
 
Join Date: Feb 2015
Posts: 5
Rep Power: 0
shafner79 is on a distinguished road
Default

Bump
shafner79 is offline   Reply With Quote
Old 03-01-2015, 11:32 AM   #3 (permalink)
Junior Member
 
Join Date: Feb 2015
Posts: 5
Rep Power: 0
shafner79 is on a distinguished road
Default

So I removed the MAF sensor, air duct and air filter. The filter was very dirty and the air duct had a lot if fluid/gunk in it. I cleaned the sensor and installed a new filter. Cleared the codes and the light came right back on and kicked the same code. Guess I'll buy a new MAF sensor and try that.
shafner79 is offline   Reply With Quote
Old 03-01-2015, 07:34 PM   #4 (permalink)
Junior Member
 
Join Date: Oct 2013
Age: 46
Posts: 4
Rep Power: 0
hockeydad is on a distinguished road
Default

I had the stabilitrak and engine light come on. It was for me P2135 which was the throttle position sensor which fixed my issue.


Sent from my iPhone using Tapatalk
hockeydad is offline   Reply With Quote
Old 03-01-2015, 10:57 PM   #5 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

Nice, sorry the snow storms have kept me away but the TPS would have been my suggestion. Just be happy you have the 1st gen model. You have to replace the throttle body on the new Equinox's.


Another fun fact about this issue, if your equinox falls in line with the powertrain wattanty as the OBS, it was covered. This is not the case on the NBS even though without the throttle body, the powertrain could not operate.
dietz4ibanez is offline   Reply With Quote
Old 03-10-2015, 02:17 PM   #6 (permalink)
Junior Member
 
Join Date: Feb 2015
Posts: 5
Rep Power: 0
shafner79 is on a distinguished road
Default

I replaced the MAF sensor today and still got the same CEL code. Guess I'll try the TPS now.....
shafner79 is offline   Reply With Quote
Old 03-14-2015, 10:11 AM   #7 (permalink)
Junior Member
 
Join Date: Feb 2015
Posts: 5
Rep Power: 0
shafner79 is on a distinguished road
Default

Fixed. Had a blown 10a fuse for the MAF circuit. CEL and Service Stabilitrak light out.
dietz4ibanez likes this.
shafner79 is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 Equinox LT MIL, limp mode, service stabilitrak Babsmitty 2010+ Equinox Maintenance 2 01-21-2015 04:27 PM
abs traction control light on jman3624 2010+ Equinox General Forum 0 09-22-2014 08:19 PM
2008 Equinox Sport 3.6 Timing Chain thedotz 05-09 Equinox General Forum 1 07-29-2013 09:30 AM
Aftermarket HU questions - 2008 Nox Sport kjlee2112 05-09 Equinox General Forum 0 07-05-2013 12:48 AM