Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 05-09 Equinox Maintenance

05-09 Equinox Maintenance

'07 Chugging around 40-50 mph?


This is a discussion on '07 Chugging around 40-50 mph? within the 05-09 Equinox Maintenance forums, part of the Chevy Equinox General Discussion category!
I don't know if this is the right place to be asking this but...Just in the last week our 2007 ...





Reply
 
LinkBack Thread Tools Display Modes
Old 04-24-2013, 02:28 PM   #1 (permalink)
Junior Member
 
Join Date: Apr 2013
Posts: 2
Rep Power: 0
Siegs55 is on a distinguished road
Default '07 Chugging around 40-50 mph?

I don't know if this is the right place to be asking this but...Just in the last week our 2007 Equinox started "chugging" around 40-50 mph. The second I put my foot on the gas it's seems fine. Talking to a few people they suggested it might be the plugs. Does anyone else know of this issue and how to fix it?

Thanks.
Siegs55 is offline   Reply With Quote
Old 04-25-2013, 11:17 AM   #2 (permalink)
Senior Member
 
TheDarkKnightKnox's Avatar
 
Join Date: Apr 2012
Location: Columbus, OHIO
Age: 34
Posts: 268
Rep Power: 8
TheDarkKnightKnox is on a distinguished road
Default

I had a similar issue on an older car, It ended up needing new plugs and wires.

We tested by placing the car in Drive and pressing on the brake and accelerator at the same time. The issue was recreated.
__________________
"12 Nox LTZ 3.0L (TheDarkKnight) 55K Miles
TheDarkKnightKnox is offline   Reply With Quote
Old 04-25-2013, 06:03 PM   #3 (permalink)
Junior Member
 
Join Date: Apr 2013
Posts: 2
Rep Power: 0
Siegs55 is on a distinguished road
Default

Thanks. I appreciate the input.
Siegs55 is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On