Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum

Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum (http://www.chevyequinoxforum.com/)
-   05-09 Equinox General Forum (http://www.chevyequinoxforum.com/f36/)
-   -   Brand new issue - rough idle and stall after driving - 05 Equinox (http://www.chevyequinoxforum.com/f36/brand-new-issue-rough-idle-stall-after-driving-05-equinox-1370/)

beigmatt 06-15-2015 11:16 AM

Brand new issue - rough idle and stall after driving - 05 Equinox
 
Just today I took the car for a 20 minute drive, pulled into my parking spot and it was idling very rough and then shut off. Now my engines proceeds to turn on, idle rough and then completely shut off. I am almost positive (I checked 4-6 weeks ago, but will check again) that there are no vaccum leaks, about a month ago I changed the air filter and cleaned the throttle body and MAF.

https://www.youtube.com/watch?v=aG0m05osrAc

I am hoping based on this video someone has some insight outside of the basics. Thank you!!!!!!

beigmatt 06-15-2015 01:09 PM

EDIT: here is a closeup video of the engine. https://www.youtube.com/watch?v=IVUyEHPnEPg
Note: It really sounds like the valves are hitting the pistons. To me the engine always sounds like this starting up. even the throttle body and fuel pump sounds loud when I turn the key over.

beigmatt 06-16-2015 10:03 AM

I had my friend pump gas 2 days ago. But the gas cas was tight. I even jumped up and down on the car to mix things up. Very weird that fuel would be a problem. Would I had to of gotten a bad batch with water??

I just don't think its a fuel issue. I did remember hitting a hot wire right off the battery with my wrench when I was doing my coolant reservoir last week. Any chance that could cause a relay to SLOWLY go bad?

I really have alot more to look at before you guys can truly solve this without crapshooting I feel. This can point so many directions. I will try to go get some information within the next 2 hours. Thanks much for everyones help so far. Gotta get under the hood. I will give the community some real results. I have driven this car for 6 years straight, putting 120k on it with 2 different engines. I have put alot of work into the car. So this is a very abnormal issue for me, with most likely a simple solution.

So last night I was able to test a couple things. The batterys charging and cranking power was in the green.

I tested cylinder #2 and #4 by putting the spark plug in the wire and taping it so it was visible. and there was no spark going to the plug while cranking the engine.
I have not tested any relays yet, but checked all the major fuses and they are OK. Where should I proceed. Test crank sensor?

The fuel pump/relay is also still not officially ruled out.

beigmatt 06-16-2015 10:52 PM

Quote:

Originally Posted by Purple pit (Post 474764)
I'm going to say ICM, but do to the high cost having it tested at a parts store is the best way. The crank sensor is somewhat cheap, so if you can't get the ICM tested try that.

Alas! The fuel fump 10amp fuse was bad. This was a learning experience as I rarely have electrical issues. I am a fool because:

I should have checked ALL fuses, not just high amp ones.
I shouldn't have assumed it wasn't a fuel problem because I could smell fuel when cranking (for the 20 min I tried at work after it died)
I should have tested the spark plugs properly.

Thank for everyone's help :flipthebird:

dietz4ibanez 09-26-2015 11:18 PM

Quote:

Originally Posted by beigmatt (Post 12749)
Alas! The fuel fump 10amp fuse was bad. This was a learning experience as I rarely have electrical issues. I am a fool because:

I should have checked ALL fuses, not just high amp ones.
I shouldn't have assumed it wasn't a fuel problem because I could smell fuel when cranking (for the 20 min I tried at work after it died)
I should have tested the spark plugs properly.

Thank for everyone's help :flipthebird:

Glad you got it figured out!


All times are GMT -4. The time now is 06:56 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO