Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Chevy Equinox General Discussion > 05-09 Equinox General Forum

05-09 Equinox General Forum

2008 LS - trouble starting, etc.


This is a discussion on 2008 LS - trouble starting, etc. within the 05-09 Equinox General Forum forums, part of the Chevy Equinox General Discussion category!
Recently I've been having some intermittent trouble starting my 2008 Chevy Equinox LS. The problem only occurs when I leave ...





Reply
 
LinkBack Thread Tools Display Modes
Old 06-01-2013, 05:51 PM   #1 (permalink)
Junior Member
 
Join Date: Jun 2013
Posts: 3
Rep Power: 0
crj123082 is on a distinguished road
Default 2008 LS - trouble starting, etc.

Recently I've been having some intermittent trouble starting my 2008 Chevy Equinox LS. The problem only occurs when I leave my daughter's daycare after dropping her off in the morning...so it's the second start of the day, after about a 5 minute drive. All other times the car starts fine. Here's a rundown of the symptoms:

-May 9th or 10th: I tried starting the car (at the daycare) and the engine made sort of a buzzer sound, and didn't start. Then, after a few seconds, I tried it again and it started right up.

-May 11th: I did some interstate driving (about a 1.5 hour trip each way). On the trip up, after about an hour or so, I received the following warnings: "Service Traction Control" and "Service Stabilitrack." After I turned off the car the warnings have never come back on (I have no idea if this is related to the starting problem, but figured I would mention it - any advice on this issue independently would also be greatly appreciated).

-May 18th: while sitting at a stoplight, the car was idling roughly - I had to really hold down the brake to prevent the car from lurching forward, and the RPMs were going between about 800 and 1500...haven't noticed any rough idling since, though.

-May 20-24 & 27-29: Again, when leaving the daycare in the morning, when I try to start the car, it sounds like a machine gun. It usually won't start the first time, but will the second time after still making that noise. Here's a video of this, I hope it helps: video. The odd thing, though, is that it hasn't done it the last two times I've left the daycare (I doubt the problem just fixed itself, but I have no idea).

Thanks for any help or suggestions you can offer!
crj123082 is offline   Reply With Quote
Old 06-04-2013, 09:50 AM   #2 (permalink)
Junior Member
 
Join Date: Jun 2013
Posts: 3
Rep Power: 0
crj123082 is on a distinguished road
Default

Just as a follow-up, I replaced my battery (it was on its last leg anyway) but it did not solve the problem.
crj123082 is offline   Reply With Quote
Old 07-31-2015, 10:30 PM   #3 (permalink)
Junior Member
 
Join Date: Jul 2015
Posts: 1
Rep Power: 0
07Equinox is on a distinguished road
Default

this is pretty old, but thought i'd leave a few more breadcrumbs. i'm still dealing with this problem after 2.5 years. I believe it all started when Best Buy installed a GPS incorrectly- they wired it straight into the body control module (BCM). my car intermittently would not start. it got to the point where it was nearly every day, but if i waited 10 minutes it would start like nothing ever happened. other times it would start but the stabilitrak light would come on.

I'm learning as I go along, and also learning the dealerships will take advantage of electrical problems, since they're so hard to diagnose- but that is another topic... I had the BCM replaced and it fixed everything (except the damn key getting stuck in the ignition and my inoperable windshield wiper fluid pump) for a few months. The exact problems started up again, and later they went on to replace the junction block. Whether that was actually bad or not.. and then they wanted to replace the Transmission Control Module, at which point i said give me my car back. I took it somewhere else and they said the BCM was bad.. so i'm back to square one. replacing it again next week. So this isn't necessarily over but, the BCM in your case is a strong contender. I also talked to another mechanic that said it was a weak point in the Equinox and should have been recalled.
07Equinox is offline   Reply With Quote
Old 08-01-2015, 08:43 AM   #4 (permalink)
Junior Member
 
Join Date: Jun 2013
Posts: 3
Rep Power: 0
crj123082 is on a distinguished road
Default

I ended up fixing the starting/rough idling issue by adding fuel injector cleaner to a few successive tanks of gas. Now I just do that a couple times a year and haven't had the same problem since.

As for the "Service Traction Control" and "Service Stabilitrack" warnings, that was somehow a symptom of a bad EGR valve. I found that solution online and haven't gotten those warnings after replacing the valve (I was able to do that myself).

Good luck with your issue. I think the electric system in the 08 Equinox is a weak link - I had to replace the radio/CD player just a few months after buying the car (new), and have had intermittent issues with the A/C switching from intake to recycle and turning the compressor on and off (I think that is a problem with one of the radiator fans not turning on and the system getting too hot, though).
crj123082 is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
starting problems dan112 2010+ Equinox Maintenance 4 09-25-2015 11:09 PM
2010 Equinox LTZ 6 cyl starting problem johns4949 2010+ Equinox General Forum 5 05-01-2015 10:13 AM
Starting problems, gas smell, shifting issues.. Helene74 2010+ Equinox Maintenance 13 05-22-2012 08:25 AM
2008 Equinox Driving Troubles solericardo 05-09 Equinox General Forum 13 04-25-2012 12:22 PM
problem with starting point on navigation cyndi516 The Official "How To:" Section 2 04-16-2011 10:41 PM