Go Back   Chevy Equinox Forum | GMC Terrain Forum | Cadillac SRX Forum > Equinox, Terrain & SRX Modifications > Engine & Performance Modifications

Engine & Performance Modifications

Cel p0017


This is a discussion on Cel p0017 within the Engine & Performance Modifications forums, part of the Equinox, Terrain & SRX Modifications category!
I have had an intermittent diagnostic code on the Terrain's dash for the past month, and am puzzled after replacing ...





Like Tree5Likes
  • 1 Post By Qrsterling
  • 1 Post By Qrsterling
  • 1 Post By dietz4ibanez
  • 1 Post By Qrsterling
  • 1 Post By Crashandburn1980

Reply
 
LinkBack Thread Tools Display Modes
Old 01-29-2015, 07:15 AM   #1 (permalink)
Junior Member
 
Join Date: Jan 2015
Location: Reading PA
Age: 53
Posts: 3
Rep Power: 0
Qrsterling is on a distinguished road
Default Cel p0017

I have had an intermittent diagnostic code on the Terrain's dash for the past month, and am puzzled after replacing the Crank sensor. The 4 hour job (had to remove cat. conv. and exhaust pipe to access back side of engine block) at the local mechanic removed the check engine light, and allowed me to remote start the vehicle. One day later, the CEL came back on. I also replaced one of the camshaft sensors on bank 1, intake side. Any suggestions on a fix?
thomas1 likes this.
Qrsterling is offline   Reply With Quote
Old 01-29-2015, 07:39 AM   #2 (permalink)
Junior Member
 
Join Date: Jan 2015
Location: Reading PA
Age: 53
Posts: 3
Rep Power: 0
Qrsterling is on a distinguished road
Default

The CEL P0017 is on my 2010 Terrain 3.0L V-6. Replaced only 1 of the 4 cam sensors so far.
thomas1 likes this.
Qrsterling is offline   Reply With Quote
Old 01-30-2015, 12:33 AM   #3 (permalink)
Admin
 
dietz4ibanez's Avatar
 
Join Date: Jun 2010
Location: North Carolina
Age: 36
Posts: 4,670
Rep Power: 10
dietz4ibanez is on a distinguished road
Default

I would like to think that if there was a issue with your cam sensors as a precautionary measure I would think they would not allow your engine to fire.

They be be measuring and reporting back an unevenness in your timing. Could be a stretched timing chain. How many miles are on your vehicle?

I'm still hoping it's one of the 4 sensors, though.
thomas1 likes this.
dietz4ibanez is offline   Reply With Quote
Old 01-30-2015, 08:45 PM   #4 (permalink)
Junior Member
 
Join Date: Jan 2015
Location: Reading PA
Age: 53
Posts: 3
Rep Power: 0
Qrsterling is on a distinguished road
Default

Have 109,000 miles. It doesn't fire as quickly as it used to, but does start and runs fine. Is it possible that I have to visit a dealer to have a re-learn procedure performed?
thomas1 likes this.
Qrsterling is offline   Reply With Quote
Old 03-12-2016, 12:48 PM   #5 (permalink)
Junior Member
 
Join Date: Mar 2016
Age: 39
Posts: 1
Rep Power: 0
Crashandburn1980 is on a distinguished road
Default 2010 terrain p0014 and p0017

Hi all need help asap found my gmc to have these codes and only these codes I'm a Chrysler tech so I do not have access to gm scan tool but they told me to replace the motor I'm like no way. Of course no warranty engine runs fine just the light is on plz helpb
thomas1 likes this.
Crashandburn1980 is offline   Reply With Quote
Old 05-21-2016, 08:34 AM   #6 (permalink)
Junior Member
 
Join Date: May 2016
Posts: 1
Rep Power: 0
teddybear05 is on a distinguished road
Default

I have that same code p0014 on 2010 chevy equinox. And we took it to a repair shop and they change the variable valve timing solenoid both of them. And the code stayed off for three months and then the check engine light came on again and that same code came up and then we took it to the repair shop again and they found nothing wrong with the solenoid and they change the oil again and this time they put synthetic oil in it. And not even a week later the check engine light came on again, same code. So please help
teddybear05 is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On