View Single Post
Old 02-17-2019, 06:02 PM   #21 (permalink)
tshryock
Junior Member
 
Join Date: Feb 2019
Age: 51
Posts: 1
Rep Power: 0
tshryock is on a distinguished road
Default

I had the same issue -- steering controls worked as did the touchscreen, but none of the buttons for favorites or power for radio would work. I read the other posts and one person suggested that it might be related to remote start -- which I had used the night before (and maybe buttons weren't working then either, but I didn't try them until today.) The one suggested solution by a poster was to start the car using the key fob -- I did this and it worked. Hopefully it will stick.
I think what may be happening is that the controls are inactive until you put a key in, but in some cases, the key doesn't "wake up" all the controls, and they stay inoperative. By restarting remotely, it resets the system -- as does removing the positive battery cable, which would explain why that solution works also.
So if you are having this problem, I would try remote starting with key fob first, and if that doesn't work, remove the positive battery cable to reset the computer.
Good luck!
tshryock is offline   Reply With Quote