View Single Post
Old 11-27-2018, 10:48 AM   #1 (permalink)
Ftrevino19
Junior Member
 
Join Date: Nov 2018
Age: 29
Posts: 2
Rep Power: 0
Ftrevino19 is on a distinguished road
Default 2011 chevy equinox running rough and stalling. Please help.

My 2011 chevy equinox has been running rough for past 6 months its been feeling jerky sometimes stall when im at a light, sometimes hesitates when pressing on the gas. All this started happening after getting caught in middle of a bad flood had to drive through it for a bit to get to higher grounds. Car didnt act up that night,next day engine light came on.. No milky like oil or water in air filter but was a bad o2 sensor. I changed it out. worked fine for a couple weeks. Then started running rough again. Bad o2 sensor again same one. Changed it out worked fine for a few weeks. THen again started running rough. Code came up it was a bad Catalytic converter. Dealer changed it out and high pressure fuel pump. Covered by dealer due to recalls. That seemed to fix the problem for a few months. Well about a week ago it start acting funny again. Car went into "reduced engine power" mode. Came up tps was no good. So of course changed it out with the throttle body its one unit.. Work for a couple days, but now running rough again. Took it to a mechanic says only thing is coming up is a bad o2 sensor. The same one ive replaced twice already. I explained to him about driving through flooded water some time back. Says maybe the computer got damaged when i drove through the water which could be why i keep getting different codes. I havent changed out the o2 sensor yet. Please help
Ftrevino19 is offline   Reply With Quote