View Single Post
Old 08-01-2017, 04:27 PM   #1 (permalink)
MyEquioxblah
Junior Member
 
Join Date: Aug 2014
Posts: 2
Rep Power: 0
MyEquioxblah is on a distinguished road
Default 2008 Equinox Hot Start Problem

Hey all...so I have seen many different posts across the web regarding this but not answers.
2008 Chevy Equinox starts just fine when the engine is cold. When the engine is warm and turned off and it sits for about 45 minutes or more; it will start however, it cranks and cranks and cranks before it starts. It does the whole take your hand off the key and it continues to try and start on it's own.
Seems that pressing on the accelerator helps.
Once it starts it runs fine.
I've tried turning the key to the on position to allow the fuel pump to prime but that does not help.
Sometimes and rarely when it starts there'e a loud clunking...almost like the starter is getting kicked back (the only way I can really describe it).
A side note. I don't know if this is a coincidence but this didn't start until after I had brought it in to the dealership for warranty repair which consisted of:
- New plug wires.
- Replacement sensor in the Throttle body.
- New fuel pump.

I have brought this in multiple times and all they say is "we can't get it to do it, it starts just fine for us". It does this every single day for me...like clock work. Bunch of a holes!

No SES light. No codes in the computer.
I'm in Chicago and it's been decently hot here if that helps.

Anyone....anyone???
MyEquioxblah is offline   Reply With Quote